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1. Simple Programs with Control Structures 

 
Apparatus Required 

1. Microsoft Visual Basic 2017 

 

Theory 

Control structures allow you to control the flow of your program's execution. If left unchecked by 

control-flow statements, a program's logic will flow through statements from left to right, and top to 

bottom. While some very simple programs can be written with only this unidirectional flow, and while 

some flow can be controlled by using operators to regulate precedence of operations, most of the power 

and utility of any programming language comes from its ability to change statement order with structures 

and loops. 

• If...Then...Else 

• Select...Case 

• Try...Catch...Finally 

• While...End While 

• Do...Loop 

• For...Next 

• For Each...Next 

• Using...End Using 

• With...End With 

 

DoWhile.vb 

Program 

Module DoWhile 

 

    Sub Main() 

Console.Title = "Do While Loop" 

        Dim i As Integer = 0 

        Do While i <= 100 

            If i > 10 Then 

                Exit Do 

            End If 

 

            Debug.Write(i.ToString & " ") 

            Console.Write(i.ToString & " ") 

            i += 1 

        Loop 

 

        Debug.WriteLine("") 

        Console.WriteLine("") 

        Console.ReadKey() 

    End Sub 

 

End Module 



Output 

 
 

 
 

StarPattern.vb 

Program 

Module StarPattern 

 

    Sub Main() 

Console.Title = "Star Pattern" 

        Dim i As Integer 

        Dim j As Integer 

        Dim k As Integer 

        For i = 1 To 5 Step 1 

            For j = 4 To i Step -1 

                Console.Write(" ") 

            Next j 

            For k = 1 To (2 * i - 1) Step 1 

                Console.Write("*") 

            Next k 

            Console.WriteLine() 

        Next i 

        Console.ReadKey() 

 

    End Sub 

End Module 

 

Output 

 
 



Form1.vb 

Program 

Public Class Form1 

 

    Private Sub RadioButton1_CheckedChanged(sender As Object, e As EventArgs) Handles 
RadioButton1.CheckedChanged, RadioButton2.CheckedChanged, RadioButton3.CheckedChanged, 
CheckBoxBacon.CheckedChanged, CheckBoxGarlic.CheckedChanged, 
CheckBoxRanch.CheckedChanged, CheckBoxKetchup.CheckedChanged, 
CheckBoxPeppers.CheckedChanged 

        Dim sum As Double 

 

        If CheckBoxBacon.Checked Then sum += 500 

        If CheckBoxGarlic.Checked Then sum += 500 

        If CheckBoxRanch.Checked Then sum += 500 

        If CheckBoxKetchup.Checked Then sum += 500 

        If CheckBoxPeppers.Checked Then sum += 500 

        If RadioButton1.Checked Then sum += 1000 

        If RadioButton2.Checked Then sum += 2000 

        If RadioButton3.Checked Then sum += 3000 

        TextBox1.Text = (sum) 

 

    End Sub 

 

    Private Sub newpoc1() Handles MyBase.Activated 

 

        ListBox1.SelectedIndex = 0 

        ListBox1.Focus() 

    End Sub 

 

    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click 

        RadioButton1.Checked = False 

        RadioButton2.Checked = False 

        RadioButton3.Checked = False 

        ListBox1.Select() 

 

        CheckBoxBacon.Checked = False 

        CheckBoxGarlic.Checked = False 

        CheckBoxRanch.Checked = False 

        CheckBoxKetchup.Checked = False 

        CheckBoxPeppers.Checked = False 

 

        ListBox1.SelectedIndex = Not 0 

        ListBox1.SelectedIndex = 0 

        ListBox1.Focus() 

 

    End Sub 

 

    Private Sub Button2_Click(sender As Object, e As EventArgs) Handles Button2.Click 

        End 

    End Sub 

 



End Class 

Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



2. Adding Menus to Forms 
 

Apparatus Required 

1. Microsoft Visual Basic 2017 

 

Theory 

A menu is a set of options presented to the user of a computer application to help the user find 

information or execute a program function. Menus are common in graphical user interfaces ( GUI s) such 

as Windows or the Mac OS . Menus are also employed in some speech recognition programs. 

Menus are vital to any application. Depending on the program, the menus enable the user to 

physically use your program. The user chooses whichever menu and the program responds accordingly—

whether it is showing a dialog box, or changing the color of the words, or exiting. 

Menus allow you to arrange commands in a logical and easy-to-find fashion. A menu shouldn't 

contain paragraphs of text, or even long sentences; its sole purpose is to help you navigate through the 

entire program. 

 

Program 

Form1.vb 
Public Class Form1 

    Private Sub ExperimentToolStripMenuItem_Click(sender As Object, e As EventArgs) 
Handles ExperimentToolStripMenuItem.Click 

        MessageBox.Show("You have selected New Experiment", "New Experiment", 
MessageBoxButtons.OK, MessageBoxIcon.Information) 

    End Sub 

 

    Private Sub ExitToolStripMenuItem_Click(sender As Object, e As EventArgs) Handles 
ExitToolStripMenuItem.Click 

        Dim result = MessageBox.Show("Are you sure you want to exit ", "Exit", 
MessageBoxButtons.YesNo, MessageBoxIcon.Warning) 

 

        If result = DialogResult.Yes Then 

            Me.Close() 

        End If 

    End Sub 

 

    Private Sub CopyrightToolStripMenuItem_Click(sender As Object, e As EventArgs) 
Handles CopyrightToolStripMenuItem.Click 

        MessageBox.Show("Copyright © Robert Innocent Karamagi 2017 ", "Copyright", 
MessageBoxButtons.OK, MessageBoxIcon.Information) 

    End Sub 

End Class 

 

 

 

 

http://searchsoftwarequality.techtarget.com/definition/application
http://searchwindevelopment.techtarget.com/definition/GUI
http://searchwindowsserver.techtarget.com/definition/Windows
http://whatis.techtarget.com/definition/Mac-OS
http://searchcrm.techtarget.com/definition/speech-recognition


Output 

 

 

 



 

 

 
 

 

 

 

 

 

 

 



3. Creating Dialog boxes with various options 
 

Apparatus Required 

1. Microsoft Visual Basic 2017 

 

Theory 

All of these dialog box control classes inherit from the CommonDialog class and override 
the RunDialog() function of the base class to create the specific dialog box. 

The RunDialog() function is automatically invoked when a user of a dialog box calls its 
ShowDialog() function.  

The ShowDialog method is used to display all the dialog box controls at run-time. It returns 
a value of the type of DialogResult enumeration. The values of DialogResult enumeration are: 

Abort - Cancel - Ignore  - No   -None  -OK - Retry  - Yes  

 

ColorDialog- It represents a common dialog box that displays available colors along with controls 
that enable the user to define custom colors. 

FontDialog -It prompts the user to choose a font from among those installed on the local computer 
and lets the user select the font, font size, and color. 

OpenFileDialog -It prompts the user to open a file and allows the user to select a file to open. 

SaveFileDialog - It prompts the user to select a location for saving a file and allows the user to 
specify the name of the file to save data. 

PrintDialog - It lets the user to print documents by selecting a printer and choosing which sections 
of the document to print from a Windows Forms application. 

 

Program 

Form1.vb 
Public Class Form1 

    Private Sub btnOpen_Click(sender As Object, e As EventArgs) Handles btnOpen.Click 

        Dim FileReader As StreamReader 

        Dim results As DialogResult 

        results = OpenFileDialog.ShowDialog 

        If results = DialogResult.OK Then 

            FileReader = New StreamReader(OpenFileDialog.FileName) 

            txtBox.Text = FileReader.ReadToEnd() 

            FileReader.Close() 

        End If 

    End Sub 

 

    Private Sub btnSave_Click(sender As Object, e As EventArgs) Handles btnSave.Click 

        Dim FileWriter As StreamWriter 

        Dim results As DialogResult 

        results = SaveFileDialog.ShowDialog 

        If results = DialogResult.OK Then 

https://www.tutorialspoint.com/vb.net/vb.net_color_dialog.htm
https://www.tutorialspoint.com/vb.net/vb.net_font_dialog.htm
https://www.tutorialspoint.com/vb.net/vb.net_openfile_dialog.htm
https://www.tutorialspoint.com/vb.net/vb.net_savefile_dialog.htm
https://www.tutorialspoint.com/vb.net/vb.net_print_dialog.htm


            FileWriter = New StreamWriter(SaveFileDialog.FileName, False) 

            FileWriter.Write(txtBox.Text) 

            FileWriter.Close() 

 

        End If 

    End Sub 

 

 

    Private Sub btnBrowse_Click(sender As Object, e As EventArgs) Handles btnBrowse.Click 

        OpenFileDialog.ShowDialog() 

        If OpenFileDialog.FileName > "" Then 

            picBox.ImageLocation = OpenFileDialog.FileName 

        End If 

    End Sub 

 

    Private Sub btnExit_Click(sender As Object, e As EventArgs) Handles btnExit.Click 

        Dim result = MessageBox.Show("Are you sure you want to Exit.", "Exit", 
MessageBoxButtons.YesNo, MessageBoxIcon.Warning) 

 

        If result = DialogResult.Yes Then 

            Me.Close() 

        End If 

    End Sub 

 

    Private Sub btnSave2_Click(sender As Object, e As EventArgs) Handles btnSave2.Click 

        SaveFileDialog.ShowDialog() 

        If SaveFileDialog.FileName > "" Then 

            picBox.Image.Save(SaveFileDialog.FileName) 

        End If 

    End Sub 

End Class 

 

Output 

 



 

 
 

 

 

 

 

 

 

 

 

 

 

 

 



4. Multiple Document Interface Applications 
 

Apparatus Required 

1. Microsoft Visual Basic 2017 

 

Theory 

The multiple-document interface (MDI) allows you to create an application that maintains 
multiple forms within a single container form. Applications such as Microsoft Excel and Microsoft 
Word for Windows have multiple-document interfaces. 

 

An MDI application allows the user to display multiple documents at the same time, with 
each document displayed in its own window. Documents or child windows are contained in a 
parent window, which provides a workspace for all the child windows in the application. For 
example, Microsoft Excel allows you to create and display multiple-document windows of different 
types. Each individual window is confined to the area of the Excel parent window. When you 
minimize Excel, all of the document windows are minimized as well; only the parent window's icon 
appears in the task bar. 

 

A child form is an ordinary form that has its MDIChild property set to True. Your application 
can include many MDI child forms of similar or different types. 

 

At run time, child forms are displayed within the workspace of the MDI parent form (the 
area inside the form's borders and below the title and menu bars). When a child form is minimized, 
its icon appears within the workspace of the MDI form instead of on the taskbar 

 

Program  

Form1.vb 
Public Class Form1 

    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click 

        Dim Window As New Child 

        Window.MdiParent = Me 

        Window.Show() 

 

    End Sub 

End Class 

 

MDI.vb [Design] 

 



 
 

Child.vb 
Public Class Child 

 

    Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click 

        Me.Close() 

    End Sub 

End Class 

 

Child.vb[Design] 

 
 

 

 

 



Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



5. Writing code for various Keyboard and Mouse Events 
 

Apparatus Required 

1. Microsoft Visual Basic 2017 

Theory 

Keyboard and Mouse are two most important input devices. When user uses these devices, Visual 

Basic generates a set of events. 

 

  When user presses a key on the keyboard, Visual Basic generates a few events. These events allow 

user to know which key is exactly pressed. Keyboard events occur for the controls that can receive input. 

Keydown event occurs when user has pressed a key from keyboard. KeyUp event occurs when user releases 

a key that he has pressed earlier. That means every KeyDown event is followed by a KeyUp event. 

KeyAscii When user presses and releases an ANSI key. A key code is the code of the key pressed. 

Keypress event occurs when user presses and releases a key. 

 

Mouse events occur when user presses and releases mouse buttons. The following are the events 

related to mouse. 

 

MouseClick – When the user presses and releases a mouse button. 

MouseDoubleclick - When the user presses and releases and again presses and releases a mouse button. 

MouseDown - When the user presses a mouse button. 

MouseUp - When the user releases a mouse button. 

MouseMove - When the user moves the mouse pointer. 

MouseWheel - When the user scrolls the mouse wheel 

MouseHover - When the mouse pointer is on top of an area 

MouseLeave - When the mouse pointer leaves the top of an area 

MouseEnter - When the user selects with the mouse 

 

Keyboard Events 

Program 

Form1.vb 
Public Class Form1 

    Private Sub Form1_KeyDown(sender As Object, e As KeyEventArgs) Handles Me.KeyDown 

 

        If e.KeyValue = Keys.Up Then 

            labelUp.Text = "Up Pressed" 

        End If 

 

        If e.KeyValue = Keys.Down Then 

            labelDown.Text = "Down Pressed" 

        End If 

 



        If e.KeyValue = Keys.Left Then 

            labelLeft.Text = "Left Pressed" 

        End If 

 

        If e.KeyValue = Keys.Right Then 

            labelRight.Text = "Right Pressed" 

        End If 

    End Sub 

 

    Private Sub Form1_KeyUp(sender As Object, e As KeyEventArgs) Handles Me.KeyUp 

 

        If e.KeyValue = Keys.Up Then 

            labelUp.Text = "Up Not Pressed" 

        End If 

 

        If e.KeyValue = Keys.Down Then 

            labelDown.Text = "Down Not Pressed" 

        End If 

 

        If e.KeyValue = Keys.Left Then 

            labelLeft.Text = "Left Not Pressed" 

        End If 

 

        If e.KeyValue = Keys.Right Then 

            labelRight.Text = "Right Not Pressed" 

        End If 

    End Sub 

End Class 

 

Output 

 



Mouse Events 

Program 

Form1.vb 
Public Class Form1 

 

    Private Sub PBRed_MouseHover(sender As Object, e As EventArgs) Handles 
PBRed.MouseHover 

        PBGreen.Visible = True 

        PBRed.Visible = False 

 

    End Sub 

 

    Private Sub PBGreen_MouseLeave(sender As Object, e As EventArgs) Handles 
PBGreen.MouseLeave 

        PBRed.Visible = True 

        PBGreen.Visible = False 

 

    End Sub 

 

    Private Sub txtBoxMouse_MouseMove(sender As Object, e As MouseEventArgs) Handles 
txtBoxMouse.MouseMove 

        txtBoxMouse.Text = "x=" & e.X & "; y= " & e.Y 

    End Sub 

 

    Private Sub txtBoxScroll_MouseWheel(sender As Object, e As MouseEventArgs) Handles 
txtBoxScroll.MouseWheel 

        If e.Delta > 0 Then 

            txtBoxScroll.Text = "Mouse is Scrolling Up" 

        Else 

            txtBoxScroll.Text = "Mouse is Scrolling Down" 

        End If 

 

    End Sub 

 

 

    Private Sub btnMouse_MouseDown(sender As Object, e As MouseEventArgs) Handles 
btnMouse.MouseDown 

        txtBoxClick.BackColor = Color.Olive 

        txtBoxClick.Text = "This is a Mouse Down Event" 

    End Sub 

 

    Private Sub btnMouse_MouseUp(sender As Object, e As MouseEventArgs) Handles 
btnMouse.MouseUp 

        txtBoxClick.BackColor = Color.Tomato 

        txtBoxClick.Text = "This is a Mouse Up Event" 

       

    End Sub 

End Class 

 

 



Output 

Form1.vb [Design] 

 

 
 

Mouse Draw 

Program  
Public Class Form1 

 

    Dim shouldpaint As Boolean = True 

 

    Private Sub Form1_Load(sender As Object, e As EventArgs) 

 

    End Sub 

 

    Private Sub Form1_MouseMove(sender As Object, e As MouseEventArgs) Handles 
Me.MouseMove 



        If shouldpaint Then 

            Dim graphic As Graphics = CreateGraphics() 

            graphic.FillEllipse(New SolidBrush(Color.BlueViolet), e.X, e.Y, 5, 5) 

        End If 

    End Sub 

 

    Private Sub Form1_MouseUp(sender As Object, e As MouseEventArgs) Handles 
MyBase.MouseUp 

        shouldpaint = False 

    End Sub 

 

    Private Sub Form1_MouseDown(sender As Object, e As MouseEventArgs) Handles 
Me.MouseDown 

        shouldpaint = True 

    End Sub 

 

    Private Sub Form1_DoubleClick(sender As Object, e As EventArgs) Handles 
MyBase.DoubleClick 

        Dim g As Graphics = CreateGraphics() 

        g.Clear(BackColor) 

 

    End Sub 

End Class 

 

Output 

 
 



6. Object Linking and Embedding Container Control 
 

Apparatus Required 

1. Microsoft Visual Basic  

2. Microsoft Excel 2016 

 

Theory 

 

OLE (Object Linking and Embedding) is a means to interchange data between applications.  

 

OLE Server 

  This is an application that can provide objects to other applications. This is also called as OLE 

Source application. 

 

OLE Client 

  This is an application that uses objects provided by OLE Server. This is also called as OLE 

Container as it contains objects provided by OLE Server. 

 

  In object embedding, an object is embedded in the client application. The advantage with Object 

Embedding is, client application maintains its own copy of the data. The disadvantage is, changes made to 

original data (in source application) will not be incorporated in the data maintained by client. 

 

  Object linking makes changes made to source application available to container application. This is 

because container doesn’t store a separate copy of the data, instead it maintains a link to data in source 

application. 

 

OLE Container Control 

  In Visual Basic, you can embed or link an object using OLE container control. OLE control is one of 

the standard set of controls. This allows you to either embed or link an object either at design time or at 

run time thorough its properties and methods. 

 

 

Program 

 Sheet2(Code) 
Sub openForm() 

    OLE.Show 

    OLE.TextBox1.SetFocus 

End Sub 

 

 



Sheet2 (Object) 

 

 
 

OLE.xlsm - [OLE(Code)] 
Private Sub CommandButton1_Click() 

    If TextBox1.Value = "" Or TextBox2.Value = "" Or TextBox3.Value = "" Then 

        If MsgBox("Form is not complete. Do you want to continue?", vbQuestion + vbYesNo) 
<> vbYes Then 

            Exit Sub 

        End If 

    End If 

 



    ActiveCell = TextBox1.Value 

    ActiveCell.Offset(0, 1) = TextBox2.Value 

    ActiveCell.Offset(0, 2) = TextBox3.Value 

 

    ActiveCell.Offset(1, 0).Select 

 

    Call resetForm() 

 

End Sub 

 

Sub resetForm() 

 

    TextBox1.Value = "" 

    TextBox2.Value = "" 

    TextBox3.Value = "" 

    OLE.TextBox1.SetFocus 

 

End Sub 

 

Output 

 

 



 

 
 

 

 

 

 

 

 

 

 

 

 

 

 



7. Simple Programs with Classes and Objects 
 

Apparatus Required 

1. Microsoft Visual Basic 2017 

 

Theory 

A class is an abstract representation of something, whereas an object is a usable example of the 

thing the class represents. An object is a structure that contains data and methods that manipulate the 

data. Classes consist of fields, properties, methods, and events. Fields and properties represent 

information that an object contains. Properties are retrieved and set like fields, but are implemented by 

property Get and property Set procedures, which provide more control on how values are set or returned. 

Methods represent actions that an object can perform. Encapsulation means that a group of related 

properties, methods, and other members are treated as a single unit or object. Inheritance describes the 

ability to create new classes based on an existing class. Polymorphism means that you can have multiple 

classes that can be used interchangeably, even though each class implements the same properties or 

methods in different ways. Overloaded members are used to provide different versions of a property or 

method that have the same name, but that accept different number of parameters, or parameters with 

different data types. Overridden properties and methods are used to replace an inherited property or 

method that is not appropriate in a derived class.  

 

Program 

OOP.vb 
Public Class OOP 

 

    Dim obj As New Copyright 

    Private Sub btnCopyright_Click(sender As Object, e As EventArgs) Handles 
btnCopyright.Click 

        obj.info() 

    End Sub 

 

 

End Class 

 

Public Class Copyright 

 

    Sub info() 

        MsgBox("Copyright © Robert Karamagi 2017", MsgBoxStyle.Information) 

    End Sub 

 

End Class 

 

 

 

 



Output 

 

 
 

Volume.vb 

 
 

Program 
Module Volume 

    Class Box 

        Public length As Double   ' Length of a box 

        Public width As Double   ' Breadth of a box 

        Public height As Double    ' Height of a box 

    End Class 

    Sub Main() 

  Console.Title = "Classes and Objects" 

        Dim b1 As Box = New Box()        ' Declare Box1 of type Box 

        Dim b2 As Box = New Box()        ' Declare Box2 of type Box 

        Dim volume As Double = 0.0     ' Store the volume of a box here 



        ' box 1 specification 

        b1.height = 5.0 

        b1.length = 6.0 

        b1.width = 7.0 

        ' box 2 specification 

        b2.height = 10.0 

        b2.length = 12.0 

        b2.width = 13.0 

        'volume of box 1 

        volume = b1.height * b1.length * b1.width 

        Console.WriteLine("Volume of Box1 : {0}", volume) 

        'volume of box 2 

        volume = b2.height * b2.length * b2.width 

        Console.WriteLine("Volume of Box2 : {0}", volume) 

        Console.ReadKey() 

    End Sub 

End Module 

 

 

Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 



8. Data Access through Data Control and Data Access 

Objects 
Apparatus Required 

1. Microsoft Visual Basic 2017 

2. Microsoft Access 2016 

 

Theory 

Data Control provides access to data stored in databases using any one of three types of Recordset 

objects. The Data control enables you to move from record to record and to display and manipulate data 

from the records in bound controls. Without a Data control or an equivalent data source control like the 

RemoteData control, data-aware (bound) controls on a form can't automatically access data. 

Data Access Objects (DAO) enable you to manipulate the structure of your database and the data 

it contains from Visual Basic. Many DAO objects correspond to objects that you see in your database—for 

example, a TableDef object corresponds to a Microsoft Access table. A Field object corresponds to a field 

in a table. 

ActiveX Data Objects (ADO) -  The bridge between the data providers and data consumers is 

through data sources created using Microsoft ActiveX Data Objects (ADO), which is the primary method in 

Visual Basic to access data in any data source, both relational and non-relational. 

 
Program 
Public Class Form1 

    Private Sub EmployeeDataBindingNavigatorSaveItem_Click(sender As Object, e As 
EventArgs) Handles EmployeeDataBindingNavigatorSaveItem.Click 

        Me.Validate() 

        Me.EmployeeDataBindingSource.EndEdit() 

        Me.TableAdapterManager.UpdateAll(Me.EmployeeInfoDataSet) 

 

    End Sub 

 

    Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load 

        Me.EmployeeDataTableAdapter.Fill(Me.EmployeeInfoDataSet.EmployeeData) 

 

    End Sub 

 

    Private Sub btnAdd_Click_1(sender As Object, e As EventArgs) Handles btnAdd.Click 



        EmployeeDataBindingSource.AddNew() 

    End Sub 

 

    Private Sub btnSave_Click_1(sender As Object, e As EventArgs) Handles btnSave.Click 

        Try 

            EmployeeDataBindingSource.EndEdit() 

            EmployeeDataTableAdapter.Update(EmployeeInfoDataSet.EmployeeData) 

            MessageBox.Show("Employee Saved Successfully.", "Success", 
MessageBoxButtons.OK, MessageBoxIcon.Information) 

 

 

        Catch ex As Exception 

            MessageBox.Show("Error occured while saving.", "Error", MessageBoxButtons.OK, 
MessageBoxIcon.Error) 

 

        End Try 

    End Sub 

 

    Private Sub btnDelete_Click_1(sender As Object, e As EventArgs) Handles 
btnDelete.Click 

        Dim result = MessageBox.Show("Are you sure you want to Delete.", "Delete 
Confirmation", MessageBoxButtons.YesNo, MessageBoxIcon.Warning) 

 

        If result = DialogResult.Yes Then 

            EmployeeDataBindingSource.RemoveCurrent() 

        End If 

 

    End Sub 

End Class 

 

Output 

Microsoft Access Database  

 



Form1.vb[Design]

 
 

 
 

 

 

 

 

 

 

 



 

 

 

 

 
 

 

 

 

 

 



1. Creating Applications with App Wizard 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

A software wizard or setup assistant is a user interface type that presents a user with a sequence 

of dialog boxes that lead the user through a series of well-defined steps. Tasks that are complex, 

infrequently performed, or unfamiliar may be easier to perform using a wizard. 

Every type of Visual C++ project has an application wizard that helps you generate new projects 

quickly and easily, modeled from the project template. 

Visual C++ provides wizards that work in conjunction with the MFC application framework and the 

Active Template Library to create starter programs for you. 

 

Procedure 

a) File-> New Project -> MFC Application 

b) Set Application as Dialog Based. 

c) Place the Edit Control. 

d) Add a Timer Variable-> Category: Value, Variable Type: int 

e) Add a Comment Variable-> Category: Value, Variable Type: CString 

f) Browse to the Class View, On the program “Dlg” file open the OnInitDialog() which is 

similar to the Form_Load and add the code for the timer. 

 
SetTimer(1, 1000, NULL); 

 

g) On the “Dlg” file in the class view, go to its Properties and select “Messages” . Scroll to 

WM_TIMER, and add OnTimer Event. 

 

h) Add the Timer Handler code: 
UpdateData(true); 

Timer = Timer + 1; 

if (Timer == 5) {   

KillTimer(nIDEvent);  

 Comments = "Time is Up"; 

 UpdateData(false); 

} 

UpdateData(false); 

 

 

 

 



Program 

Counter.h 
#pragma once 

 

#ifndef __AFXWIN_H__ 

 #error "include 'stdafx.h' before including this file for PCH" 

#endif 

 

#include "resource.h"  

 

 

class CCounterApp : public CWinApp 

{ 

public: 

 CCounterApp(); 

 

public: 

 virtual BOOL InitInstance(); 

 

 

 

 DECLARE_MESSAGE_MAP() 

}; 

 

extern CCounterApp theApp; 

 

Counter.cpp 
#include "stdafx.h" 

#include "Counter.h" 

#include "CounterDlg.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

BEGIN_MESSAGE_MAP(CCounterApp, CWinApp) 

 ON_COMMAND(ID_HELP, &CWinApp::OnHelp) 

END_MESSAGE_MAP() 

 

 

CCounterApp::CCounterApp() 

{ 

  m_dwRestartManagerSupportFlags = AFX_RESTART_MANAGER_SUPPORT_RESTART; 

} 

 

CCounterApp theApp; 

 

BOOL CCounterApp::InitInstance() 

{ 



 INITCOMMONCONTROLSEX InitCtrls; 

 InitCtrls.dwSize = sizeof(InitCtrls); 

 InitCtrls.dwICC = ICC_WIN95_CLASSES; 

 InitCommonControlsEx(&InitCtrls);  

CWinApp::InitInstance(); 

 AfxEnableControlContainer(); 

CShellManager *pShellManager = new CShellManager; 

 CMFCVisualManager::SetDefaultManager(RUNTIME_CLASS(CMFCVisualManagerWindows)); 

 SetRegistryKey(_T("Local AppWizard-Generated Applications")); 

 CCounterDlg dlg; 

 m_pMainWnd = &dlg; 

 INT_PTR nResponse = dlg.DoModal(); 

 if (nResponse == IDOK) 

 { 

 } 

 else if (nResponse == IDCANCEL) 

 { 

   

 } 

 else if (nResponse == -1) 

 { 

  TRACE(traceAppMsg, 0, "Warning: dialog creation failed, so application is 
terminating unexpectedly.\n"); 

  TRACE(traceAppMsg, 0, "Warning: if you are using MFC controls on the 
dialog, you cannot #define _AFX_NO_MFC_CONTROLS_IN_DIALOGS.\n"); 

 } 

 if (pShellManager != NULL) 

 { 

  delete pShellManager; 

 } 

 

#if !defined(_AFXDLL) && !defined(_AFX_NO_MFC_CONTROLS_IN_DIALOGS) 

 ControlBarCleanUp(); 

#endif 

 return FALSE; 

} 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Output 
 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



2. Drawing in documents 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

Nearly all drawing in your application occurs in the view's OnDraw member function, which 
you must override in your view class. Your OnDraw override: 

1. Gets data by calling the document member functions you provide. 

2. Displays the data by calling member functions of a device-context object that the 
framework passes to OnDraw. 

When a view becomes invalid, Windows sends it a WM_PAINT message. The view's OnPaint 
handler function responds to the message by creating a device-context object of class CPaintDC 
and calls your view's OnDraw member function. You do not normally have to write an overriding 
OnPaint handler function. 

The UpdateAllViews member function of class CDocument and the OnUpdate member 
function of class CView lets you pass information describing what parts of the document were 
modified. When a view becomes invalid, Windows sends it a WM_PAINT message. 

A device context is a Windows data structure that contains information about the drawing 

attributes of a device such as a display or a printer. All drawing calls are made through a device-

context object. For drawing on the screen, OnDraw is passed a CPaintDC object. For drawing on a 

printer, it is passed a CDC object set up for the current printer. 

 

Procedure 

a) Start  a New MFC Project as a Single Document and Static Library; remove any un-

necessary features. 

b) Open the class view and under the program “View.cpp” OnDraw() method, place the 

following code. 
const vector<CPoint> & linePoints = pDoc->GetLinePoints(); 

 

 int sizeLinePoints = linePoints.size(); 

 if (linePoints.size() > 0) 

 { 

  CPen pen(PS_SOLID, 4, RGB(0, 200, 0)); 

  CPen *oldPen = pDC->SelectObject(&pen); 

  pDC->MoveTo(linePoints[0]); 

  for (int i = 1; i < sizeLinePoints; i++) 

  { 

   pDC->LineTo(linePoints[i]); 

  } 

  pDC->SelectObject(oldPen); 

 } 

https://msdn.microsoft.com/en-us/library/a48eab8d.aspx
https://msdn.microsoft.com/en-us/library/azz5wt61.aspx
https://msdn.microsoft.com/en-us/library/fxhhde73.aspx


 

c) In the program “Doc.h” include the header: 

 
#include <vector> 

 

Add the code in the file: 
protected: 

 vector<CPoint> m_linePoints; 

 

const vector<CPoint> & GetLinePoints() 

      { 

  return m_linePoints; 

      } 

   

    void AddLinePoint(const CPoint & point) 

      { 

  m_linePoints.push_back(point); 

} 

 

d) In the program “View.h” add the code: 
protected: 

 bool m_mouseDragging { false }; 
 

e) Open the class view and under the program “Doc.cpp” Serialize(CArchive &ar) 

method place the following code: 

 
if (ar.IsStoring()) 

{ 

  int size = m_linePoints.size(); 

  ar << size; 

 

  for (auto point : m_linePoints) 

   ar << point.x << point.y; 

 

          } 

 

     else 

     { 

  int size; 

  ar >> size; 

  CPoint point; 

  for (int i = 0; i < size; i++) 

   ar >> point.x >> point.y; 

  m_linePoints.push_back(point); 

 

} 

 



f) Open the Class view under the application “View” open it’s Properties and select 

Messages. Click on the WM_LBUTTONDOWN event and enter the code: 
if (pDoc) 

 { 

 

  //start of mouse drag 

  m_mouseDragging = true; 

 

  //add a new line point 

  pDoc->AddLinePoint(point); 

 

  //draw the new data 

  Invalidate(); 

  UpdateWindow(); 

 } 

Next Click on the WM_LBUTTONUP event and enter the code: 

m_mouseDragging = false; 

 

    Also on the WM_MOUSEMOVE add the code: 

  if (m_mouseDragging) 

  { 

   CPaintDoc* pDoc = GetDocument(); 

   ASSERT_VALID(pDoc); 

   if (pDoc) 

   { 

    //add a new line point 

    pDoc->AddLinePoint(point); 

  

    //draw the new data 

    Invalidate(); 

    UpdateWindow(); 

   } 

  } 

 

g) In the Class view in the program “Doc” double click on the OnNewDocument() 

method and add the code: 

 
m_linePoints.clear(); 

 

Next for the OnOpenDocument(LPCTSTR lpszPathName) add the code 
m_linePoints.clear(); as well. 

 

 

 

 

 



Program 

PaintView.h 
#pragma once 

 

 

class CPaintView : public CView 

{ 

protected: 

 CPaintView(); 

 DECLARE_DYNCREATE(CPaintView) 

public: 

 CPaintDoc* GetDocument() const; 

 

public: 

 

public: 

 virtual void OnDraw(CDC* pDC);   

 virtual BOOL PreCreateWindow(CREATESTRUCT& cs); 

protected: 

 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo); 

 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo); 

 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo); 

 

public: 

 virtual ~CPaintView(); 

#ifdef _DEBUG 

 virtual void AssertValid() const; 

 virtual void Dump(CDumpContext& dc) const; 

#endif 

 

protected: 

 bool m_mouseDragging 

 {  

  false  

 }; 

 

protected: 

 afx_msg void OnFilePrintPreview(); 

 afx_msg void OnRButtonUp(UINT nFlags, CPoint point); 

 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point); 

 DECLARE_MESSAGE_MAP() 

public: 

 

 afx_msg void OnLButtonDown(UINT nFlags, CPoint point); 

 afx_msg void OnLButtonUp(UINT nFlags, CPoint point); 

 afx_msg void OnMouseMove(UINT nFlags, CPoint point); 

}; 

 

#ifndef _DEBUG   

inline CPaintDoc* CPaintView::GetDocument() const 



   { return reinterpret_cast<CPaintDoc*>(m_pDocument); } 

#endif 

 

PaintView.cpp 
#include "stdafx.h" 

#ifndef SHARED_HANDLERS 

#include "Paint.h" 

#endif 

 

#include "PaintDoc.h" 

#include "PaintView.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

using namespace std; 

 

IMPLEMENT_DYNCREATE(CPaintView, CView) 

 

BEGIN_MESSAGE_MAP(CPaintView, CView) 

  

 ON_COMMAND(ID_FILE_PRINT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_DIRECT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_PREVIEW, &CPaintView::OnFilePrintPreview) 

 ON_WM_CONTEXTMENU() 

 ON_WM_RBUTTONUP() 

 ON_WM_LBUTTONDOWN() 

 ON_WM_LBUTTONUP() 

 ON_WM_MOUSEMOVE() 

END_MESSAGE_MAP() 

 

void CPaintView::OnDraw(CDC* pDC) 

{ 

 CPaintDoc* pDoc = GetDocument(); 

 ASSERT_VALID(pDoc); 

 if (!pDoc) 

  return; 

 

 const vector<CPoint> & linePoints = pDoc->GetLinePoints(); 

 

 int sizeLinePoints = linePoints.size(); 

 if (linePoints.size() > 0) 

 { 

  CPen pen(PS_SOLID, 4, RGB(0, 200, 0)); 

  CPen *oldPen = pDC->SelectObject(&pen); 

  pDC->MoveTo(linePoints[0]); 

  for (int i = 1; i < sizeLinePoints; i++) 

  { 

   pDC->LineTo(linePoints[i]); 



  } 

  pDC->SelectObject(oldPen); 

 } 

} 

 

 

 

void CPaintView::OnRButtonUp(UINT /* nFlags */, CPoint point) 

{ 

 ClientToScreen(&point); 

 OnContextMenu(this, point); 

} 

 

void CPaintView::OnContextMenu(CWnd* /* pWnd */, CPoint point) 

{ 

#ifndef SHARED_HANDLERS 

 theApp.GetContextMenuManager()->ShowPopupMenu(IDR_POPUP_EDIT, point.x, point.y, 
this, TRUE); 

#endif 

} 

 

#ifdef _DEBUG 

void CPaintView::AssertValid() const 

{ 

 CView::AssertValid(); 

} 

 

void CPaintView::Dump(CDumpContext& dc) const 

{ 

 CView::Dump(dc); 

} 

 

CPaintDoc* CPaintView::GetDocument() const  

{ 

 ASSERT(m_pDocument->IsKindOf(RUNTIME_CLASS(CPaintDoc))); 

 return (CPaintDoc*)m_pDocument; 

} 

#endif  

 

void CPaintView::OnLButtonDown(UINT nFlags, CPoint point) 

{ 

 CPaintDoc* pDoc = GetDocument(); 

 ASSERT_VALID(pDoc); 

 if (pDoc) 

 { 

 

  

  m_mouseDragging = true; 

 

  pDoc->AddLinePoint(point); 

 



  Invalidate(); 

  UpdateWindow(); 

 } 

 CView::OnLButtonDown(nFlags, point); 

} 

 

void CPaintView::OnLButtonUp(UINT nFlags, CPoint point) 

{ 

  

 m_mouseDragging = false;  

 CView::OnLButtonUp(nFlags, point); 

} 

 

void CPaintView::OnMouseMove(UINT nFlags, CPoint point) 

{ 

 if (m_mouseDragging) 

 { 

  CPaintDoc* pDoc = GetDocument(); 

  ASSERT_VALID(pDoc); 

  if (pDoc) 

  { 

    

   pDoc->AddLinePoint(point); 

   Invalidate(); 

   UpdateWindow(); 

  } 

 } 

 CView::OnMouseMove(nFlags, point); 

} 

 

Output 

 
 



3. Working with Microsoft Foundation Classes 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

 

  MFC is a SDK interface, a library consisting in a set of classes that act as wrappers around 
portions of the Windows API, so that C++ programmers may program Windows using some 
concepts of the object-oriented programming (OOP) paradigm and the C++ language (the Win32 
API is based on C). One should learn the Win32 API or at least have some ideas since some 
functions are absent from the MFC and would help you to better understand the SDK. 

 

  Some tools, such as Microsoft Visual Studio, are capable of automatically generating large 
amounts of MFC skeleton code for use in a project. Because of this, most MFC tutorials or 
reference materials will teach the subject using the automated Visual Studio tools, and leave out 
some of the gritty details.  

 

  MFC was first oriented mostly for enterprise-level programming projects, created in an age 
most code was done in C and Object-Oriented Programming was only in the realm of Smalltalk. 

 

  MFC is a library that wraps portions of the Windows API in C++ classes, including 
functionality that enables them to use a default application framework. Classes are defined for 
many of the handle-managed Windows objects and also for predefined windows and common 
controls. 

  

Procedure 

1. Start the dialog based MFC Application. Name =Login 

2. In the Resource View ->Dialog -> IDD_LOGIN_DIALOG.  

3. Place the Static Text from the toolbox : 

Caption= Username: ID = IDC_STATIC_UName   

Caption= Password: ID = IDC_STATIC_UPass 

4. Place the Edit Control from the Toolbox 

Username-> IDC_EDIT_UName 

Password-> IDC_EDIT_UPass : Password =TRUE 

5. Place the Button 

Caption: Login:  ID= IDC_BUTTON_Login 

Default Button = TRUE 

6. Right Click on the Username Edit Control and select Add Variable 

Category=Value   ;  Variable name= UName ;   Variable Type: CString 

https://en.wikipedia.org/wiki/Software_development_kit
https://en.wikipedia.org/wiki/Windows_API
https://en.wikipedia.org/wiki/Microsoft_Visual_Studio
https://en.wikipedia.org/wiki/Wrapper_library
https://en.wikipedia.org/wiki/Class_(computer_programming)
https://en.wikipedia.org/wiki/Application_framework
https://en.wikipedia.org/wiki/Handle_(computing)


Add a variable for Password: 

Category=Value   ;  Variable name= UPass ;   Variable Type: CString 

7. Open the Class View. Go to CLoginDlg(observe the name from step 1). Select the 

Properties-> Events -> IDC_BUTTON_Login -> BN_CLICKED 

Add the code to the generated method in LoginDlg.cpp 

 
UpdateData(TRUE); 

 if (UName == "Robert" && UPass == "1234") { 

  AfxMessageBox(_T("Login is Successful")); 

  CProfileDlg in; 

  CDialogEx::OnOK(); 

  in.DoModal(); 

 

 } 

 else { 

  AfxMessageBox(_T("Invalid login credentials")); 

   

 } 

 UpdateData(FALSE); 
 

8. In the Resource View ->Dialog -> Insert Dialog. Click on it’s Properties and set: 

Caption= Welcome ;  ID= IDD_DIALOG_Profile;   

 

<<<Place any text or picture .>>> 

For a picture: Place the Picture Control;  Type: Bitmap ; Image:<Any uploaded image ID 

available in your resources> 

 

9. Place the Logout Button.  

 

10. On the Dialog window , Right Click and Add Class -> Class Name = CProfileDlg -> Finish  

 

11. In the LoginDlg.cpp add the header file by #include "ProfileDlg.h" 

 

12. Double Click on the Logout Button and include the code: 
CLoginDlg out; 

 CDialogEx::OnOK(); 

out.DoModal(); 
 

13. In the ProfileDlg.cpp add the header file by #include "LoginDlg.h" 

 

 

 

 



Program 

Login.h 
#pragma once 

 

#ifndef __AFXWIN_H__ 

#endif 

 

#include "resource.h"   

 

class CLoginApp : public CWinApp 

{ 

public: 

 CLoginApp(); 

public: 

 virtual BOOL InitInstance(); 

 

 DECLARE_MESSAGE_MAP() 

}; 

 

extern CLoginApp theApp; 

 

LoginDlg.h 
 

#pragma once 

 

class CLoginDlg : public CDialogEx 

{ 

public: 

 CLoginDlg(CWnd* pParent = NULL);  

 

#ifdef AFX_DESIGN_TIME 

 enum { IDD = IDD_LOGIN_DIALOG }; 

#endif 

 

 protected: 

 virtual void DoDataExchange(CDataExchange* pDX);  

protected: 

 HICON m_hIcon; 

  

 virtual BOOL OnInitDialog(); 

 afx_msg void OnSysCommand(UINT nID, LPARAM lParam); 

 afx_msg void OnPaint(); 

 afx_msg HCURSOR OnQueryDragIcon(); 

 DECLARE_MESSAGE_MAP() 

public: 

 CString UName; 

 CString UPass; 

 afx_msg void OnBnClickedButtonLogin(); 

}; 



 

ProfileDlg.h 
#pragma once 

#include "afxwin.h" 

 

class CProfileDlg : public CDialogEx 

{ 

 DECLARE_DYNAMIC(CProfileDlg) 

 

public: 

 CProfileDlg(CWnd* pParent = NULL);    

 virtual ~CProfileDlg(); 

 

#ifdef AFX_DESIGN_TIME 

 enum { IDD = IDD_DIALOG_Profile }; 

#endif 

 

protected: 

 virtual void DoDataExchange(CDataExchange* pDX);     

 DECLARE_MESSAGE_MAP() 

public: 

 afx_msg void OnBnClickedButtonLogout(); 

  

}; 

 

Login.cpp 
 

#include "stdafx.h" 

#include "Login.h" 

#include "LoginDlg.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

 

BEGIN_MESSAGE_MAP(CLoginApp, CWinApp) 

 ON_COMMAND(ID_HELP, &CWinApp::OnHelp) 

END_MESSAGE_MAP() 

 

 

CLoginApp::CLoginApp() 

{ 

 m_dwRestartManagerSupportFlags = AFX_RESTART_MANAGER_SUPPORT_RESTART; 

} 

 

 

CLoginApp theApp; 

 

 



BOOL CLoginApp::InitInstance() 

{ 

 INITCOMMONCONTROLSEX InitCtrls; 

 InitCtrls.dwSize = sizeof(InitCtrls); 

  

 InitCtrls.dwICC = ICC_WIN95_CLASSES; 

 InitCommonControlsEx(&InitCtrls); 

 

 CWinApp::InitInstance(); 

 

 

 AfxEnableControlContainer(); 

 CShellManager *pShellManager = new CShellManager; 

 CMFCVisualManager::SetDefaultManager(RUNTIME_CLASS(CMFCVisualManagerWindows)); 

 SetRegistryKey(_T("Local AppWizard-Generated Applications")); 

 

 CLoginDlg dlg; 

 m_pMainWnd = &dlg; 

 INT_PTR nResponse = dlg.DoModal(); 

 if (nResponse == IDOK) 

 { 

 } 

 else if (nResponse == IDCANCEL) 

 { 

   

 } 

 else if (nResponse == -1) 

 { 

  TRACE(traceAppMsg, 0, "Warning: dialog creation failed, so application is 
terminating unexpectedly.\n"); 

  TRACE(traceAppMsg, 0, "Warning: if you are using MFC controls on the 
dialog, you cannot #define _AFX_NO_MFC_CONTROLS_IN_DIALOGS.\n"); 

 } 

 if (pShellManager != NULL) 

 { 

  delete pShellManager; 

 } 

 

#if !defined(_AFXDLL) && !defined(_AFX_NO_MFC_CONTROLS_IN_DIALOGS) 

 ControlBarCleanUp(); 

#endif 

  

 return FALSE; 

} 

 

LoginDlg.cpp 
 

#include "stdafx.h" 

#include "Login.h" 

#include "LoginDlg.h" 

#include "afxdialogex.h" 



#include "ProfileDlg.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

class CAboutDlg : public CDialogEx 

{ 

public: 

 CAboutDlg(); 

 

#ifdef AFX_DESIGN_TIME 

 enum { IDD = IDD_ABOUTBOX }; 

#endif 

 

 protected: 

 virtual void DoDataExchange(CDataExchange* pDX);    

 

protected: 

 DECLARE_MESSAGE_MAP() 

}; 

 

CAboutDlg::CAboutDlg() : CDialogEx(IDD_ABOUTBOX) 

{ 

} 

 

void CAboutDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialogEx::DoDataExchange(pDX); 

} 

 

BEGIN_MESSAGE_MAP(CAboutDlg, CDialogEx) 

END_MESSAGE_MAP() 

 

 

CLoginDlg::CLoginDlg(CWnd* pParent /*=NULL*/) 

 : CDialogEx(IDD_LOGIN_DIALOG, pParent) 

 , UName(_T("")) 

 , UPass(_T("")) 

{ 

 m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME); 

} 

 

void CLoginDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialogEx::DoDataExchange(pDX); 

 DDX_Text(pDX, IDC_EDIT_UName, UName); 

 DDX_Text(pDX, IDC_EDIT_UPass, UPass); 

} 

 

BEGIN_MESSAGE_MAP(CLoginDlg, CDialogEx) 



 ON_WM_SYSCOMMAND() 

 ON_WM_PAINT() 

 ON_WM_QUERYDRAGICON() 

 

ON_BN_CLICKED(IDC_BUTTON_Login, &CLoginDlg::OnBnClickedButtonLogin) 

END_MESSAGE_MAP() 

 

 

BOOL CLoginDlg::OnInitDialog() 

{ 

 CDialogEx::OnInitDialog(); 

 

 ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX); 

 ASSERT(IDM_ABOUTBOX < 0xF000); 

 

 CMenu* pSysMenu = GetSystemMenu(FALSE); 

 if (pSysMenu != NULL) 

 { 

  BOOL bNameValid; 

  CString strAboutMenu; 

  bNameValid = strAboutMenu.LoadString(IDS_ABOUTBOX); 

  ASSERT(bNameValid); 

  if (!strAboutMenu.IsEmpty()) 

  { 

   pSysMenu->AppendMenu(MF_SEPARATOR); 

   pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu); 

  } 

 } 

 

 SetIcon(m_hIcon, TRUE);    

 SetIcon(m_hIcon, FALSE);   

 

 return TRUE;   

} 

 

void CLoginDlg::OnSysCommand(UINT nID, LPARAM lParam) 

{ 

 if ((nID & 0xFFF0) == IDM_ABOUTBOX) 

 { 

  CAboutDlg dlgAbout; 

  dlgAbout.DoModal(); 

 } 

 else 

 { 

  CDialogEx::OnSysCommand(nID, lParam); 

 } 

} 

 

void CLoginDlg::OnPaint() 

{ 

 if (IsIconic()) 



 { 

  CPaintDC dc(this);  

 

      SendMessage(WM_ICONERASEBKGND, reinterpret_cast<WPARAM>(dc.GetSafeHdc()), 0); 

 

  

  int cxIcon = GetSystemMetrics(SM_CXICON); 

  int cyIcon = GetSystemMetrics(SM_CYICON); 

  CRect rect; 

  GetClientRect(&rect); 

  int x = (rect.Width() - cxIcon + 1) / 2; 

  int y = (rect.Height() - cyIcon + 1) / 2; 

 

   

  dc.DrawIcon(x, y, m_hIcon); 

 } 

 else 

 { 

  CDialogEx::OnPaint(); 

 } 

} 

 

HCURSOR CLoginDlg::OnQueryDragIcon() 

{ 

 return static_cast<HCURSOR>(m_hIcon); 

} 

 

void CLoginDlg::OnBnClickedButtonLogin() 

{ 

  UpdateData(TRUE); 

 if (UName == "Robert" && UPass == "1234") { 

  AfxMessageBox(_T("Login is Successful")); 

  CProfileDlg in; 

  CDialogEx::OnOK(); 

  in.DoModal(); 

 

 } 

 else { 

  AfxMessageBox(_T("Invalid login credentials")); 

   

 } 

 UpdateData(FALSE); 

 

} 

 

ProfileDlg.cpp 
 

#include "stdafx.h" 

#include "Login.h" 

#include "ProfileDlg.h" 



#include "afxdialogex.h" 

#include "LoginDlg.h" 

 

 

IMPLEMENT_DYNAMIC(CProfileDlg, CDialogEx) 

 

CProfileDlg::CProfileDlg(CWnd* pParent /*=NULL*/) 

 : CDialogEx(IDD_DIALOG_Profile, pParent) 

{ 

 

} 

 

CProfileDlg::~CProfileDlg() 

{ 

} 

 

void CProfileDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialogEx::DoDataExchange(pDX); 

  

} 

 

 

BEGIN_MESSAGE_MAP(CProfileDlg, CDialogEx) 

 ON_BN_CLICKED(IDC_BUTTON_Logout, &CProfileDlg::OnBnClickedButtonLogout) 

  

END_MESSAGE_MAP() 

 

 

void CProfileDlg::OnBnClickedButtonLogout() 

{ 

 CLoginDlg out; 

 CDialogEx::OnOK(); 

 

 out.DoModal(); 

 

} 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

Output 

 

 
 

 
 

 

 

 

 



4. Creating SDI and MDI Applications 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

MFC makes it easy to work with both single-document interface (SDI) and multiple-
document interface (MDI) applications. 

 

SDI applications allow only one open document frame window at a time. MDI 
applications allow multiple document frame windows to be open in the same instance of an 
application. An MDI application has a window within which multiple MDI child windows, which 
are frame windows themselves, can be opened, each containing a separate document. In some 
applications, the child windows can be of different types, such as chart windows and 
spreadsheet windows. In that case, the menu bar can change as MDI child windows of different 
types are activated. 

 

 

Procedure 

SDI  

1. Start a new MFC Application of Single Document Type. 

2. Open the OnDraw() method in the Application’s View Class. 

 
pDC->TextOutW(50, 50, m_strName); 

 pDC->TextOutW(70, 70, m_strPlace); 

pDC->TextOutW(100, 100, (CString) "Single Document Interface Application"); 

 

3. In the Application’s View Class, open the constructor method with the same name as the 

class and paste the variable definitions: 
CSDIView::CSDIView() 

{ 

 m_strName = "Robert Karamagi"; 

 m_strPlace = "St. Joseph University"; 

} 

4. Define the variable’s in the application View.h  
protected: 

CString m_strName; 

CString m_strPlace; 

 

 

 



Program 

SDIView.h 
 

#pragma once 

 

class CSDIView : public CView 

{ 

protected: CSDIView(); 

 DECLARE_DYNCREATE(CSDIView) 

 CString m_strName; 

 CString m_strPlace; 

  

public: 

 CSDIDoc* GetDocument() const; 

 

public: 

 

public: 

 virtual void OnDraw(CDC* pDC);   virtual BOOL PreCreateWindow(CREATESTRUCT& cs); 

protected: 

 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo); 

 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo); 

 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo); 

 

public: 

 virtual ~CSDIView(); 

#ifdef _DEBUG 

 virtual void AssertValid() const; 

 virtual void Dump(CDumpContext& dc) const; 

#endif 

 

protected: 

 

 

protected: 

 afx_msg void OnFilePrintPreview(); 

 afx_msg void OnRButtonUp(UINT nFlags, CPoint point); 

 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point); 

 DECLARE_MESSAGE_MAP() 

}; 

 

#ifndef _DEBUG   

   { return reinterpret_cast<CSDIDoc*>(m_pDocument); } 

#endif 

 

 

 

 



SDIView.cpp 
 

#include "stdafx.h" 

#ifndef SHARED_HANDLERS 

#include "SDI.h" 

#endif 

 

#include "SDIDoc.h" 

#include "SDIView.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

IMPLEMENT_DYNCREATE(CSDIView, CView) 

 

BEGIN_MESSAGE_MAP(CSDIView, CView) 

 ON_COMMAND(ID_FILE_PRINT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_DIRECT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_PREVIEW, &CSDIView::OnFilePrintPreview) 

 ON_WM_CONTEXTMENU() 

 ON_WM_RBUTTONUP() 

END_MESSAGE_MAP() 

 

 

CSDIView::CSDIView() 

{ 

 m_strName = "Robert Karamagi"; 

 m_strPlace = "St. Joseph University"; 

 

} 

 

CSDIView::~CSDIView() 

{ 

} 

 

BOOL CSDIView::PreCreateWindow(CREATESTRUCT& cs) 

{ 

 

 return CView::PreCreateWindow(cs); 

} 

 

void CSDIView::OnDraw(CDC* pDC) 

{ 

 CSDIDoc* pDoc = GetDocument(); 

 ASSERT_VALID(pDoc); 

 if (!pDoc) 

  return; 

 

 pDC->TextOutW(50, 50, m_strName); 

 pDC->TextOutW(70, 70, m_strPlace); 



 pDC->TextOutW(100, 100, (CString) "Single Document Interface Application"); 

 

} 

 

 

void CSDIView::OnRButtonUp(UINT /* nFlags */, CPoint point) 

{ 

 ClientToScreen(&point); 

 OnContextMenu(this, point); 

} 

 

void CSDIView::OnContextMenu(CWnd* /* pWnd */, CPoint point) 

{ 

#ifndef SHARED_HANDLERS 

 theApp.GetContextMenuManager()->ShowPopupMenu(IDR_POPUP_EDIT, point.x, point.y, 
this, TRUE); 

#endif 

} 

 

 

#ifdef _DEBUG 

void CSDIView::AssertValid() const 

{ 

 CView::AssertValid(); 

} 

 

void CSDIView::Dump(CDumpContext& dc) const 

{ 

 CView::Dump(dc); 

} 

 

CSDIDoc* CSDIView::GetDocument() const { 

 ASSERT(m_pDocument->IsKindOf(RUNTIME_CLASS(CSDIDoc))); 

 return (CSDIDoc*)m_pDocument; 

} 

#endif  

 

 

 

 

 

 

 

 

 

 

 



Output 

 

 
 

MDI 

1. Start a new MFC Application of Multi Document Type. 

2. Open the Class View -> In the Application Document Class -> Open the 

OnNewDocument() method and paste the code: 

 
MessageBoxW(NULL, L"You are opening a new document", L"New Window", 

MB_ICONINFORMATION |MB_OK); 

 

3. In the Application View.h add the variable declaration 

 
CString m_strTitle; 

 

4. In the Application’s View Class, open the constructor method with the same name as the 

class and paste the variable definitions: 
CMDIView::CMDIView() 

{ 

 m_strTitle = "Multiple Document Interface"; 

} 

5. In the application’s  View class -> onDraw() method add the code: 

 
pDC->TextOutW(50, 50, m_strTitle); 

 

 



Program 

MDIView.h 
 

#pragma once 

 

class CMDIView : public CView 

{ 

protected:  

 CMDIView(); 

 DECLARE_DYNCREATE(CMDIView) 

 CString m_strTitle; 

 

public: 

 CMDIDoc* GetDocument() const; 

 

public: 

 

public: 

 virtual void OnDraw(CDC* pDC);   

 virtual BOOL PreCreateWindow(CREATESTRUCT& cs); 

protected: 

 

public: 

 virtual ~CMDIView(); 

#ifdef _DEBUG 

 virtual void AssertValid() const; 

 virtual void Dump(CDumpContext& dc) const; 

#endif 

 

protected: 

 

 

protected: 

  

 afx_msg void OnRButtonUp(UINT nFlags, CPoint point); 

 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point); 

 DECLARE_MESSAGE_MAP() 

}; 

 

#ifndef _DEBUG   

inline CMDIDoc* CMDIView::GetDocument() const 

   { return reinterpret_cast<CMDIDoc*>(m_pDocument); } 

#endif 

 

 

 

 

 



MDIView.cpp 
 

#include "stdafx.h" 

#ifndef SHARED_HANDLERS 

#include "MDI.h" 

#endif 

 

#include "MDIDoc.h" 

#include "MDIView.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

IMPLEMENT_DYNCREATE(CMDIView, CView) 

 

BEGIN_MESSAGE_MAP(CMDIView, CView) 

 ON_WM_CONTEXTMENU() 

 ON_WM_RBUTTONUP() 

END_MESSAGE_MAP() 

 

CMDIView::CMDIView() 

{ 

 m_strTitle = "Multiple Document Interface"; 

} 

 

CMDIView::~CMDIView() 

{ 

} 

 

BOOL CMDIView::PreCreateWindow(CREATESTRUCT& cs) 

{ 

 return CView::PreCreateWindow(cs); 

} 

 

void CMDIView::OnDraw(CDC* pDC) 

{ 

 CMDIDoc* pDoc = GetDocument(); 

 ASSERT_VALID(pDoc); 

 if (!pDoc) 

  return; 

 pDC->TextOutW(50, 50, m_strTitle); 

} 

 

void CMDIView::OnRButtonUp(UINT /* nFlags */, CPoint point) 

{ 

 ClientToScreen(&point); 

 OnContextMenu(this, point); 

} 

void CMDIView::OnContextMenu(CWnd* /* pWnd */, CPoint point) 

{ 



#ifndef SHARED_HANDLERS 

 theApp.GetContextMenuManager()->ShowPopupMenu(IDR_POPUP_EDIT, point.x, point.y, 
this, TRUE); 

#endif 

} 

 

#ifdef _DEBUG 

void CMDIView::AssertValid() const 

{ 

 CView::AssertValid(); 

} 

 

void CMDIView::Dump(CDumpContext& dc) const 

{ 

 CView::Dump(dc); 

} 

 

CMDIDoc* CMDIView::GetDocument() const  

{ 

 ASSERT(m_pDocument->IsKindOf(RUNTIME_CLASS(CMDIDoc))); 

 return (CMDIDoc*)m_pDocument; 

} 

#endif  

 

Output 

 
 

 

 

 



5. Exception Handling 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

Catching and dealing with exceptions are standard programming tasks. A try-catch-finally 
block is a wrapper that you put around any code where an exception might occur. 
 
A try-catch-finally block is made up of the following sections:  

• Any code that may throw an exception is placed inside the try block. 

• If an exception is thrown, the catch block is entered, and the program can perform the 
appropriate operation to recover or to alert the user. 

• The code in the finally block is always executed and can perform cleanup after an 
exception occurs. The finally block is optional.  

C++ supports three kinds of exception handling: 

• C++ exception handling 

For most C++ programs, you should use C++ exception handling, which is type-safe and 
ensures that object destructors are invoked during stack unwinding. 

• Structured exception handling(SEH) 

Windows supplies its own exception mechanism, called SEH. It is not recommended for 
C++ or MFC programming. Use SEH only in non-MFC C programs. 

• MFC exceptions 

Since version 3.0, MFC has used C++ exceptions but still supports its older exception 
handling macros, which are similar to C++ exceptions in form. 

 

Procedure 

1. Start an Empty C++ Project. 

2. In the Solution Explorer. Right Click on the Project File -> Add New Item -> C++ File 

(main.cpp) 

3. Write the following program. 

 

Program 

main.cpp 

 
#include <iostream> 

#include <ctype.h> 

#include <conio.h> 

 

using namespace std; 

https://msdn.microsoft.com/en-us/library/4t3saedz.aspx
https://msdn.microsoft.com/en-us/library/swezty51.aspx
https://msdn.microsoft.com/en-us/library/t078xe4f.aspx


 

void main() 

{ 

 try { 

  int number; 

  cout << "Enter a number from 10 to 25: \n"; 

  cin >> number; 

 

  if (number > 9 && number < 26) { 

   cout << "The number (" << number << ") is in range" << endl; 

  } 

 

  else { 

   throw number; 

  } 

 } 

 

 catch (int exHandler) { 

   cout << "The number you entered is not in range" << endl; 

 } 

 

 _getch(); 

} 

 

 

 

Output 

 
 

 

 

 

 

 

 

 



6. Loading – Editing and Adding Resources - Linking 

Resources to Applications 
 

Apparatus Required 

1. Microsoft Visual C++ 6.0 

 

Theory 

 

Visual Studio projects provide two options for handling resources: they can be linked (the 
default) or embedded. You can have both linked and embedded resources in a single project. 
However, most of the time you will want to choose one option for all resources in your project. 

 

Linked resources are stored as files in the project; during compilation the resource data is 
taken from the files and added to the manifest for the application. The application's resource file 
(.resx) stores only a relative path or link to the file on disk. 

 

With embedded resources, the resource data is stored directly in the .resx file in a text 
representation of the binary data. In either case, the resource data is compiled into the executable 
file. You can change resources from linked to embedded by changing the Persistence property for 
the resource file. 

 

Resources can be composed of a wide range of elements, including interface elements that 

provide information to the user (for example a bitmap, icon, or cursor); custom resources that 

contain data an application needs; version resources that are used by setup APIs; and menu and 

dialog box resources. 

 

 

Procedure 

1. Start a New Win32 Dynamic Link Library Project. -> Select: A Simple DLL Project. 

2. Write the respective codes in the .cpp source file and Build. 

3. Start a New MFC AppWizard(exe) -> Dialog based. Place the static text, edit controls and 

buttons. 

4. For the enter number edit controls, click Properties -> Styles -> Number 

5. For the Result edit control, click Properties -> Styles -> Number, Read Only  

6. Right click on the dialog -> Class Wizard -> Member Variables  

IDC_BOX_NO1   ->  Member Variable Name: n1;   Category : Value;    Type: Double  

IDC_BOX_NO2   ->  Member Variable Name: n2;   Category : Value;    Type: Double  

IDC_BOX_RESULT   ->  Member Variable Name: n3;   Category : Value;    Type: Double  



7. Place the import functions for all the methods “add, sub, mul, divide ”as below in the 

ApplicationDlg.cpp file. 

i.e.  ->  extern "C" _declspec(dllimport) double add(double, double); 

8. Double click on the buttons and enter the respective codes. 

9. Copy the (.dll) and (.lib) files from the DLL application into the Debug folder of the MFC 

Dialog Application. 

10. Select Project -> Add -> Files -> (Browse to Debug folder) -> Add (.lib) file to the Project. 

 

 

Program 

DLL.cpp 
 

 

#include "stdafx.h" 

 

extern "C" _declspec(dllexport) double add(double, double); 

extern "C" _declspec(dllexport) double sub(double, double); 

extern "C" _declspec(dllexport) double mul(double, double); 

extern "C" _declspec(dllexport) double divide(double, double); 

 

BOOL APIENTRY DllMain(HANDLE hModule, 

 DWORD  ul_reason_for_call, 

 LPVOID lpReserved 

) 

{ 

 return TRUE; 

} 

 

double add(double a, double b) 

{ 

 return a + b; 

} 

 

double sub(double a, double b) 

{ 

 return a - b; 

} 

 

double mul(double a, double b) 

{ 

 return a*b; 

} 

 

double divide(double a, double b) 

{ 

 return a / b; 

} 

 



 

 

CalculateDlg.cpp 
 

#include "stdafx.h" 

#include "Calculate.h" 

#include "CalculateDlg.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#undef THIS_FILE 

static char THIS_FILE[] = __FILE__; 

#endif 

 

extern "C" _declspec(dllimport) double add(double, double); 

extern "C" _declspec(dllimport) double sub(double, double); 

extern "C" _declspec(dllimport) double mul(double, double); 

extern "C" _declspec(dllimport) double divide(double, double); 

 

class CAboutDlg : public CDialog 

{ 

public: 

 CAboutDlg(); 

 enum { IDD = IDD_ABOUTBOX }; 

  

protected: 

 virtual void DoDataExchange(CDataExchange* pDX);     

 

protected: 

  

 DECLARE_MESSAGE_MAP() 

}; 

 

CAboutDlg::CAboutDlg() : CDialog(CAboutDlg::IDD) 

{ 

  

} 

 

void CAboutDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialog::DoDataExchange(pDX); 

  

} 

 

BEGIN_MESSAGE_MAP(CAboutDlg, CDialog) 

END_MESSAGE_MAP() 

 

 

CCalculateDlg::CCalculateDlg(CWnd* pParent /*=NULL*/) 

 : CDialog(CCalculateDlg::IDD, pParent) 



{ 

 n1 = 0.0; 

 n2 = 0.0; 

 n3 = 0.0; 

  

 m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME); 

} 

 

void CCalculateDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialog::DoDataExchange(pDX); 

  

 DDX_Text(pDX, IDC_BOXNO1, n1); 

 DDX_Text(pDX, IDC_BOXNO2, n2); 

 DDX_Text(pDX, IDC_BOXRESULT, n3); 

} 

 

BEGIN_MESSAGE_MAP(CCalculateDlg, CDialog) 

 ON_WM_SYSCOMMAND() 

 ON_WM_PAINT() 

 ON_WM_QUERYDRAGICON() 

 ON_BN_CLICKED(IDC_BTNADD, OnBtnadd) 

 ON_BN_CLICKED(IDC_BTNSUBTRACT, OnBtnsubtract) 

 ON_BN_CLICKED(IDC_BTNMUL, OnBtnmul) 

 ON_BN_CLICKED(IDC_BTNDIV, OnBtndiv) 

END_MESSAGE_MAP() 

 

 

BOOL CCalculateDlg::OnInitDialog() 

{ 

 CDialog::OnInitDialog(); 

 ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX); 

 ASSERT(IDM_ABOUTBOX < 0xF000); 

 

 CMenu* pSysMenu = GetSystemMenu(FALSE); 

 if (pSysMenu != NULL) 

 { 

  CString strAboutMenu; 

  strAboutMenu.LoadString(IDS_ABOUTBOX); 

  if (!strAboutMenu.IsEmpty()) 

  { 

   pSysMenu->AppendMenu(MF_SEPARATOR); 

   pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu); 

  } 

 } 

 

 SetIcon(m_hIcon, TRUE);   

 SetIcon(m_hIcon, FALSE);  

 

          

 return TRUE;   



} 

 

void CCalculateDlg::OnSysCommand(UINT nID, LPARAM lParam) 

{ 

 if ((nID & 0xFFF0) == IDM_ABOUTBOX) 

 { 

  CAboutDlg dlgAbout; 

  dlgAbout.DoModal(); 

 } 

 else 

 { 

  CDialog::OnSysCommand(nID, lParam); 

 } 

} 

 

 

void CCalculateDlg::OnPaint() 

{ 

 if (IsIconic()) 

 { 

  CPaintDC dc(this);  

 

  SendMessage(WM_ICONERASEBKGND, (WPARAM)dc.GetSafeHdc(), 0); 

  int cxIcon = GetSystemMetrics(SM_CXICON); 

  int cyIcon = GetSystemMetrics(SM_CYICON); 

  CRect rect; 

  GetClientRect(&rect); 

  int x = (rect.Width() - cxIcon + 1) / 2; 

  int y = (rect.Height() - cyIcon + 1) / 2; 

dc.DrawIcon(x, y, m_hIcon); 

 } 

 else 

 { 

  CDialog::OnPaint(); 

 } 

} 

 

HCURSOR CCalculateDlg::OnQueryDragIcon() 

{ 

 return (HCURSOR)m_hIcon; 

} 

 

 

void CCalculateDlg::OnBtnadd() 

{ 

 UpdateData(); 

 n3 = add(n1, n2); 

 UpdateData(false); 

 

} 

 



void CCalculateDlg::OnBtnsubtract() 

{ 

 UpdateData(); 

 n3 = sub(n1, n2); 

 UpdateData(false); 

 

} 

 

void CCalculateDlg::OnBtnmul() 

{ 

 UpdateData(); 

 n3 = mul(n1, n2); 

 UpdateData(false); 

 

} 

 

void CCalculateDlg::OnBtndiv() 

{ 

 UpdateData(); 

 n3 = divide(n1, n2); 

 UpdateData(false); 

 

} 

 

Output 

 

 
 



7. Drawing Bitmaps 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

 

A bitmap is a series of points (bits) arranged like a map so that, when put together, they 
produce a picture that can be written to, copied from, re-arranged, changed, manipulated, or 
stored as a computer file. Bitmaps are used to display pictures on graphical applications, word 
processors, database files, or audience presentations. To display its product on a device such as a 
monitor or a printer, a bitmap holds some properties and follows a set of rules.  

 

There are various types of bitmaps, based on the number of colors that the bitmap can 
display. First of all, a bitmap can be monochrome, in which case, each pixel corresponds to 1 bit. 
A bitmap can also be colored. The number of colors that a bitmap can display is equal to 2 raised 
to the number of pits/pixel. For example, a simple bitmap uses only 4 pits/pixel or 4 bpp can handle 
only 24 = 16 colors. A more enhanced bitmap that requires 8 bpp can handle 28 = 256 colors. 
Bitmaps are divided in two categories that control their availability to display on a device.  

 

A device-independent bitmap (DIB) is a bitmap that is designed to be loaded on any 
application or display on any device and produce the same visual effect. To make this possible, 
such a bitmap contains a table of colors that describes how the colors of the bitmap should be 
used on pixels when displaying it. The characteristics of a DIB are defined by the BITMAPINFO 
structure.  

 

A device-dependent bitmap (DDB) is a bitmap created from the BITMAP structure using 
the dimensions of the bitmap.  

 

Procedure 

1. Open the New MFCApplication -> Single Document -> Finish 

2. In the Solution Explorer -> Add New Resource -> Bitmap -> New 

3. Use the Panel Tools to draw a bitmap and Save.  

4. Open the Resource View -> Properties to set the name 

5. Open the Class View -> In the Application View -> OnDraw() method 

6. Enter the code for showing the bitmap 

 

Program 

BitmapView.h 
#pragma once 
class CBitmapView : public CView 



{ 
protected:  
 CBitmapView(); 
 DECLARE_DYNCREATE(CBitmapView) 
 
public: 
 CBitmapDoc* GetDocument() const; 
 
public: 
 
public: 
 virtual void OnDraw(CDC* pDC);   
 virtual BOOL PreCreateWindow(CREATESTRUCT& cs); 
protected: 
 virtual BOOL OnPreparePrinting(CPrintInfo* pInfo); 
 virtual void OnBeginPrinting(CDC* pDC, CPrintInfo* pInfo); 
 virtual void OnEndPrinting(CDC* pDC, CPrintInfo* pInfo); 
 
public: 
 virtual ~CBitmapView(); 
#ifdef _DEBUG 
 virtual void AssertValid() const; 
 virtual void Dump(CDumpContext& dc) const; 
#endif 
 
protected: 
 
 
protected: 
 afx_msg void OnFilePrintPreview(); 
 afx_msg void OnRButtonUp(UINT nFlags, CPoint point); 
 afx_msg void OnContextMenu(CWnd* pWnd, CPoint point); 
 DECLARE_MESSAGE_MAP() 
}; 
 
#ifndef _DEBUG   
inline CBitmapDoc* CBitmapView::GetDocument() const 
   { return reinterpret_cast<CBitmapDoc*>(m_pDocument); } 
#endif 
 

 

BitmapView.cpp 
 

#include "stdafx.h" 

#ifndef SHARED_HANDLERS 

#include "Bitmap.h" 

#endif 

 

#include "BitmapDoc.h" 

#include "BitmapView.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 



 

IMPLEMENT_DYNCREATE(CBitmapView, CView) 

 

BEGIN_MESSAGE_MAP(CBitmapView, CView) 

 ON_COMMAND(ID_FILE_PRINT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_DIRECT, &CView::OnFilePrint) 

 ON_COMMAND(ID_FILE_PRINT_PREVIEW, &CBitmapView::OnFilePrintPreview) 

 ON_WM_CONTEXTMENU() 

 ON_WM_RBUTTONUP() 

END_MESSAGE_MAP() 

 

 

CBitmapView::CBitmapView() 

{ 

 

} 

 

CBitmapView::~CBitmapView() 

{ 

} 

 

BOOL CBitmapView::PreCreateWindow(CREATESTRUCT& cs) 

{ 

  

 return CView::PreCreateWindow(cs); 

} 

 

void CBitmapView::OnDraw(CDC* pDC) 

{ 

 CBitmapDoc* pDoc = GetDocument(); 

 ASSERT_VALID(pDoc); 

 if (!pDoc) 

  return; 

 

 CBitmap bitmap; 

 

 CDC dcMemory; 

 

 bitmap.LoadBitmap(IDB_Robert); 

 

 dcMemory.CreateCompatibleDC(pDC); 

 

 dcMemory.SelectObject(&bitmap); 

 

 pDC->BitBlt(0, 0, 1000, 1000, &dcMemory, 0, 0, SRCCOPY); 

} 

 

void CBitmapView::OnFilePrintPreview() 

{ 

#ifndef SHARED_HANDLERS 

 AFXPrintPreview(this); 



#endif 

} 

 

BOOL CBitmapView::OnPreparePrinting(CPrintInfo* pInfo) 

{ 

  return DoPreparePrinting(pInfo); 

} 

 

void CBitmapView::OnBeginPrinting(CDC* /*pDC*/, CPrintInfo* /*pInfo*/) 

{ 

  

} 

 

void CBitmapView::OnEndPrinting(CDC* /*pDC*/, CPrintInfo* /*pInfo*/) 

{ 

  

} 

 

void CBitmapView::OnRButtonUp(UINT /* nFlags */, CPoint point) 

{ 

 ClientToScreen(&point); 

 OnContextMenu(this, point); 

} 

 

void CBitmapView::OnContextMenu(CWnd* /* pWnd */, CPoint point) 

{ 

#ifndef SHARED_HANDLERS 

 theApp.GetContextMenuManager()->ShowPopupMenu(IDR_POPUP_EDIT, point.x, point.y, 
this, TRUE); 

#endif 

} 

 

#ifdef _DEBUG 

void CBitmapView::AssertValid() const 

{ 

 CView::AssertValid(); 

} 

 

void CBitmapView::Dump(CDumpContext& dc) const 

{ 

 CView::Dump(dc); 

} 

 

CBitmapDoc* CBitmapView::GetDocument() const  

{ 

 ASSERT(m_pDocument->IsKindOf(RUNTIME_CLASS(CBitmapDoc))); 

 return (CBitmapDoc*)m_pDocument; 

} 

#endif  

 

 



Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



8. Threads 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

 

A thread is a basic unit to which the operating system allocates processor time and is the smallest 

piece of code that can be scheduled for execution. An application written for windows consists of one or 

more processes and a process is an instance of an executing program. A thread runs in the address space 

of the process and can use the resources which are allocated to the process. A process always has at least 

one thread of execution and it's known as the primary thread. All threads in MFC applications are 

represented by CWinThread objects. The primary thread of MFC applications is implemented as a class 

derived from CWinApp, which itself is derived directly from CWinThread class. 

 

The CreateThread function creates a new thread for a process. The creating thread must specify 

the starting address of the code that the new thread is to execute. Typically, the starting address is the 

name of a function defined in the program code (for more information, see ThreadProc). This function takes 

a single parameter and returns a DWORD value. A process can have multiple threads simultaneously 

executing the same function. 

 

Procedure 

1. Start a New Windows Desktop Project -> Console Application -> Precompiled header 

2. Write the code as follows 

 

Program 
#include "stdafx.h" 

 

#include <windows.h> 

#include <strsafe.h> 

#include <stdio.h> 

#include <conio.h> 

 

#define BUF_SIZE 255 

 

 

void ShowMessage(HANDLE hScreen, char *ThreadName, int Data, int Count) 

{ 

 TCHAR msgBuf[BUF_SIZE]; 

 size_t cchStringSize; 

 DWORD dwChars; 

 

 StringCchPrintf(msgBuf, BUF_SIZE, TEXT("Executing iteration %d of %s having data = 
%d \n"), Count, ThreadName, Data); 

https://msdn.microsoft.com/en-us/library/windows/desktop/ms682453(v=vs.85).aspx
https://msdn.microsoft.com/en-us/library/windows/desktop/ms686736(v=vs.85).aspx


 StringCchLength(msgBuf, BUF_SIZE, &cchStringSize); 

 WriteConsole(hScreen, msgBuf, cchStringSize, &dwChars, NULL); 

 Sleep(1000); 

} 

 

DWORD WINAPI Thread1(LPVOID lpParam) 

{ 

 int Data = 0; 

 int count = 0; 

 HANDLE hStdout = NULL; 

 if ((hStdout = GetStdHandle(STD_OUTPUT_HANDLE)) == INVALID_HANDLE_VALUE) 

  return 1; 

 

 Data = *((int*)lpParam); 

 

 for (count = 0; count <= 4; count++) 

 { 

  ShowMessage(hStdout, "1", Data, count); 

 } 

} 

 

 

DWORD WINAPI Thread2(LPVOID lpParam) 

{ 

 int Data = 0; 

 int count = 0; 

 HANDLE hStdout = NULL; 

 if ((hStdout = GetStdHandle(STD_OUTPUT_HANDLE)) == INVALID_HANDLE_VALUE) 

  return 1; 

 

 Data = *((int*)lpParam); 

 

 for (count = 0; count <= 7; count++) 

 { 

  ShowMessage(hStdout, "2", Data, count); 

 } 

} 

 

DWORD WINAPI Thread3(LPVOID lpParam) 

{ 

 int Data = 0; 

 int count = 0; 

 HANDLE hStdout = NULL; 

 if ((hStdout = GetStdHandle(STD_OUTPUT_HANDLE)) == INVALID_HANDLE_VALUE) 

  return 1; 

 

 Data = *((int*)lpParam); 

 for (count = 0; count <= 10; count++) 

 { 

  ShowMessage(hStdout, "3", Data, count); 

 } 



} 

 

int _tmain(int argc, _TCHAR* argv[]) 

{ 

 int Data_Thread_1 = 1; 

 int Data_Thread_2 = 2; 

 int Data_Thread_3 = 3; 

 

 HANDLE Handle_Thread1 = 0; 

 HANDLE Handle_Thread2 = 0; 

 HANDLE Handle_Thread3 = 0; 

 

 HANDLE Thread_Handles[3]; 

 

 

 Handle_Thread1 = CreateThread(NULL, 0, Thread1, &Data_Thread_1, 0, NULL); 

 if (Handle_Thread1 == NULL) 

  ExitProcess(Data_Thread_1); 

 

 Handle_Thread2 = CreateThread(NULL, 0, Thread2, &Data_Thread_2, 0, NULL); 

 if (Handle_Thread2 == NULL) 

  ExitProcess(Data_Thread_2); 

 

 Handle_Thread3 = CreateThread(NULL, 0, Thread3, &Data_Thread_3, 0, NULL); 

 if (Handle_Thread3 == NULL) 

  ExitProcess(Data_Thread_3); 

 

 Thread_Handles[0] = Handle_Thread1; 

 Thread_Handles[1] = Handle_Thread2; 

 Thread_Handles[2] = Handle_Thread3; 

 

 WaitForMultipleObjects(3, Thread_Handles, TRUE, INFINITE); 

 printf("Close Handles\n"); 

 

 CloseHandle(Handle_Thread1); 

 CloseHandle(Handle_Thread2); 

 CloseHandle(Handle_Thread3); 

 

 _getch(); 

 

} 

 

 

 

 

 

 

 

 



Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



9. OLE 
 

Apparatus Required 

1. Microsoft Visual C++ 6.0 

2. Microsoft Access 2016 

 

Theory 

OLE DB is a new data access methodology from Microsoft, an important part of the 
Universal Data Access strategy. The design allows high performance data access from any data 
source. Any tabular data is viewable through OLE DB regardless of whether it came from a 
database. This flexibility gives developers a tremendous amount of power. 

 

OLE DB's design includes the concept of a consumer and provider. The Figure shows a 
graphical representation of the OLE DB system. The consumer represents the traditional client. 
The provider places data into a tabular format and returns it to the client.  

 

 
Figure: OLE DB architecture 

 

A provider is a set of COM components that contains a series of interfaces. Because these 
are standard interfaces, any OLE DB consumer can access data from any provider. Since providers 
are COM objects, consumers can access them in any language (C++, Basic, Java, and so on). 
Implementing so many COM interfaces can be tedious. Fortunately, the OLE DB Templates in 
Visual C++ can help you create a provider.  

 

Procedure 

 

1. Create the Microsoft Access Database with some entries. Save As the (.mdb) format. 

2. Go to -> Control Panel -> Administrative Tools  -> ODBC Data Sources(32 bit) -> User 

DSN(Data Source Names) 

3. Click on Microsoft Access Database -> Add -> Microsoft Access Driver (.mdb) -> Select the 

Database -> Add the name and description and Click OK. 

4. Open Visual C++ -> New MFCAppWizard -> Single Document -> Database view without 

file support 



5. Select the ODBC Data source you have created. Recordset Type = Snapshot . Select the 

database table created in MS Access. 

6. Create the user interface on the dialog. Add the static text and edit controls 

corresponding to the MS Access database table. 

7.  Right click on the dialog -> Class Wizard -> Member Variables -> Add variables to the edit 

control boxes as collected from the ODBC. 

8. Add the Buttons for ADD, UPDATE, CLEAR and DELETE and place the respective code as in 

the program 

 

Program 

ODBCView.cpp 

 
#include "stdafx.h" 

#include "ODBC.h" 

 

#include "ODBCSet.h" 

#include "ODBCDoc.h" 

#include "ODBCView.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#undef THIS_FILE 

static char THIS_FILE[] = __FILE__; 

#endif 

 

IMPLEMENT_DYNCREATE(CODBCView, CRecordView) 

 

BEGIN_MESSAGE_MAP(CODBCView, CRecordView) 

 

 ON_BN_CLICKED(IDC_BTNADD, OnBtnadd) 

 ON_BN_CLICKED(IDC_BTNCLEAR, OnBtnclear) 

 ON_BN_CLICKED(IDC_BTNDEL, OnBtndel) 

 ON_BN_CLICKED(IDC_BTNUPDATE, OnBtnupdate) 

END_MESSAGE_MAP() 

 

CODBCView::CODBCView(): CRecordView(CODBCView::IDD) 

{ 

 m_pSet = NULL; 

} 

 

CODBCView::~CODBCView() 

{ 

} 

 

void CODBCView::DoDataExchange(CDataExchange* pDX) 

{ 

 CRecordView::DoDataExchange(pDX); 

  



 DDX_FieldText(pDX, IDC_BOXID, m_pSet->m_ID, m_pSet); 

 DDX_FieldText(pDX, IDC_BOXNAME, m_pSet->m_Name, m_pSet); 

 DDX_FieldText(pDX, IDC_BOXSAL, m_pSet->m_Salary, m_pSet); 

} 

 

BOOL CODBCView::PreCreateWindow(CREATESTRUCT& cs) 

{ 

 return CRecordView::PreCreateWindow(cs); 

} 

 

void CODBCView::OnInitialUpdate() 

{ 

 m_pSet = &GetDocument()->m_oDBCSet; 

 CRecordView::OnInitialUpdate(); 

 GetParentFrame()->RecalcLayout(); 

 ResizeParentToFit(); 

 

} 

 

#ifdef _DEBUG 

void CODBCView::AssertValid() const 

{ 

 CRecordView::AssertValid(); 

} 

 

void CODBCView::Dump(CDumpContext& dc) const 

{ 

 CRecordView::Dump(dc); 

} 

 

CODBCDoc* CODBCView::GetDocument()  

{ 

 ASSERT(m_pDocument->IsKindOf(RUNTIME_CLASS(CODBCDoc))); 

 return (CODBCDoc*)m_pDocument; 

} 

#endif  

CRecordset* CODBCView::OnGetRecordset() 

{ 

 return m_pSet; 

} 

 

void CODBCView::OnBtnadd() 

{ 

 

 m_pSet->AddNew(); 

 UpdateData(true); 

 if (m_pSet->CanUpdate()) 

  m_pSet->Update(); 

 if (!m_pSet->IsEOF()) 

  m_pSet->MoveLast(); 

 m_pSet->Requery(); 



 UpdateData(false); 

 

} 

 

void CODBCView::OnBtnclear() 

{ 

 m_pSet->SetFieldNull(NULL); 

 UpdateData(false); 

 

} 

 

void CODBCView::OnBtndel() 

{ 

 m_pSet->Delete(); 

 m_pSet->MoveNext(); 

 if (m_pSet->IsEOF()) 

  m_pSet->MoveLast(); 

 if (m_pSet->IsBOF()) 

  m_pSet->SetFieldNull(NULL); 

 UpdateData(FALSE); 

 

} 

 

void CODBCView::OnBtnupdate() 

{ 

 m_pSet->Edit(); 

 m_pSet->Update(); 

} 

 

Output 

 

 
 



 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



10. ActiveX Controls 

 
Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

An ActiveX control is a reusable software component based on the Component Object 
Model (COM) that supports a wide variety of OLE functionality and can be customized to fit many 
software needs. ActiveX controls are designed for use both in ordinary ActiveX control containers 
and on the Internet, in World Wide Web pages. You can create ActiveX controls either with MFC 
or with the Active Template Library (ATL). 

 

An ActiveX control uses several programmatic elements to interact efficiently with a 
control container and with the user. These are class COleControl, a set of event-firing functions, 
and a dispatch map.  

 

When a control is used within a control container, it uses two mechanisms to 

communicate: it exposes properties and methods, and it fires events. The following figure 

demonstrates how these two mechanisms are implemented.  

 

A control has two basic states: active and inactive. Traditionally, these states were 

distinguished by whether the control had a window. An active control had a window; an inactive 

control did not. With the introduction of windowless activation, this distinction is no longer 

universal, but still applies to many controls. 

 

 
 

Figure: Communication Between an ActiveX Control Container and an ActiveX Control 

 

Procedure 

1. Start a new MFC Application -> Dialog based. 

2. Place a Static Text ; ID = IDC_STATIC_TEXT.  

3. Add a value variable m_strSliderVal for the Static Text control. Category = Value ; Variable 

Type = CString 

4. Drag the slider control from the Toolbox, Add a control variable m_sliderCtrl for the slider. 

https://msdn.microsoft.com/en-us/library/3ax346b7.aspx
https://docs.microsoft.com/en-us/cpp/mfc/reference/colecontrol-class


5. Go to the class view. Select the Application Dlg class. Properties -> Messages  -> "WM_HSCROLL" 

-> "<Add>  
 

Place the code in the method. 

if (pScrollBar == (CScrollBar *)&m_sliderCtrl) { 

  int value = m_sliderCtrl.GetPos(); 

  m_strSliderVal.Format(_T("%d"), value); 

  UpdateData(FALSE); 

 } 

 else { 

  CDialog::OnHScroll(nSBCode, nPos, pScrollBar); 

 } 

 

6. Initialize the Slider and Static Text control inside the OnInitDialog() function. 
m_sliderCtrl.SetRange(0, 100, TRUE); 

 m_sliderCtrl.SetPos(0); 

m_strSliderVal.Format(_T("%d"), 0); 

 

Program 

SliderDlg.h 

 
#pragma once 

#include "afxcmn.h" 

 

class CSliderDlg : public CDialogEx 

{ 

public: 

 CSliderDlg(CWnd* pParent = NULL);  

 

#ifdef AFX_DESIGN_TIME 

 enum { IDD = IDD_SLIDER_DIALOG }; 

#endif 

 

 protected: 

 virtual void DoDataExchange(CDataExchange* pDX);  

 

protected: 

 HICON m_hIcon; 

 virtual BOOL OnInitDialog(); 

 afx_msg void OnSysCommand(UINT nID, LPARAM lParam); 

 afx_msg void OnPaint(); 

 afx_msg HCURSOR OnQueryDragIcon(); 

 DECLARE_MESSAGE_MAP() 

public: 

 CString m_strSliderVal; 

 CSliderCtrl m_sliderCtrl; 

 afx_msg void OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar); 

}; 



SliderDlg.cpp 

 

#include "stdafx.h" 

#include "Slider.h" 

#include "SliderDlg.h" 

#include "afxdialogex.h" 

 

#ifdef _DEBUG 

#define new DEBUG_NEW 

#endif 

 

class CAboutDlg : public CDialogEx 

{ 

public: 

 CAboutDlg(); 

#ifdef AFX_DESIGN_TIME 

 enum { IDD = IDD_ABOUTBOX }; 

#endif 

 

 protected: 

 virtual void DoDataExchange(CDataExchange* pDX);     

 DECLARE_MESSAGE_MAP() 

}; 

 

CAboutDlg::CAboutDlg() : CDialogEx(IDD_ABOUTBOX) 

{ 

} 

 

void CAboutDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialogEx::DoDataExchange(pDX); 

} 

 

BEGIN_MESSAGE_MAP(CAboutDlg, CDialogEx) 

END_MESSAGE_MAP() 

 

 

 

CSliderDlg::CSliderDlg(CWnd* pParent /*=NULL*/) 

 : CDialogEx(IDD_SLIDER_DIALOG, pParent) 

 , m_strSliderVal(_T("")) 

{ 

 m_hIcon = AfxGetApp()->LoadIcon(IDR_MAINFRAME); 

} 

 

void CSliderDlg::DoDataExchange(CDataExchange* pDX) 

{ 

 CDialogEx::DoDataExchange(pDX); 

 DDX_Text(pDX, IDC_STATIC_TEXT, m_strSliderVal); 

 DDX_Control(pDX, IDC_SLIDER1, m_sliderCtrl); 

} 



 

BEGIN_MESSAGE_MAP(CSliderDlg, CDialogEx) 

 ON_WM_SYSCOMMAND() 

 ON_WM_PAINT() 

 ON_WM_QUERYDRAGICON() 

 ON_WM_HSCROLL() 

END_MESSAGE_MAP() 

 

BOOL CSliderDlg::OnInitDialog() 

{ 

 CDialogEx::OnInitDialog(); 

 

  

 ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX); 

 ASSERT(IDM_ABOUTBOX < 0xF000); 

 

 CMenu* pSysMenu = GetSystemMenu(FALSE); 

 if (pSysMenu != NULL) 

 { 

  BOOL bNameValid; 

  CString strAboutMenu; 

  bNameValid = strAboutMenu.LoadString(IDS_ABOUTBOX); 

  ASSERT(bNameValid); 

  if (!strAboutMenu.IsEmpty()) 

  { 

   pSysMenu->AppendMenu(MF_SEPARATOR); 

   pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu); 

  } 

 } 

 

 SetIcon(m_hIcon, TRUE);    

 SetIcon(m_hIcon, FALSE);   

 

  m_sliderCtrl.SetRange(0, 100, TRUE); 

 m_sliderCtrl.SetPos(0); 

 m_strSliderVal.Format(_T("%d"), 0); 

 return TRUE;   

} 

 

void CSliderDlg::OnSysCommand(UINT nID, LPARAM lParam) 

{ 

 if ((nID & 0xFFF0) == IDM_ABOUTBOX) 

 { 

  CAboutDlg dlgAbout; 

  dlgAbout.DoModal(); 

 } 

 else 

 { 

  CDialogEx::OnSysCommand(nID, lParam); 

 } 

} 



 

 

void CSliderDlg::OnPaint() 

{ 

 if (IsIconic()) 

 { 

  CPaintDC dc(this);  

 

 SendMessage(WM_ICONERASEBKGND, reinterpret_cast<WPARAM>(dc.GetSafeHdc()), 0); 

  int cxIcon = GetSystemMetrics(SM_CXICON); 

  int cyIcon = GetSystemMetrics(SM_CYICON); 

  CRect rect; 

  GetClientRect(&rect); 

  int x = (rect.Width() - cxIcon + 1) / 2; 

  int y = (rect.Height() - cyIcon + 1) / 2; 

 

   

  dc.DrawIcon(x, y, m_hIcon); 

 } 

 else 

 { 

  CDialogEx::OnPaint(); 

 } 

} 

 

. 

HCURSOR CSliderDlg::OnQueryDragIcon() 

{ 

 return static_cast<HCURSOR>(m_hIcon); 

} 

 

 

 

void CSliderDlg::OnHScroll(UINT nSBCode, UINT nPos, CScrollBar* pScrollBar) 

{ 

  if (pScrollBar == (CScrollBar *)&m_sliderCtrl) { 

  int value = m_sliderCtrl.GetPos(); 

  m_strSliderVal.Format(_T("%d"), value); 

  UpdateData(FALSE); 

 } 

 else { 

  CDialog::OnHScroll(nSBCode, nPos, pScrollBar); 

 } 

} 

 

 

 

 

 



Output 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



11. DLLs 
 

Apparatus Required 

1. Microsoft Visual C++ 2017 

 

Theory 

A dynamic-link library (DLL) is an executable file that acts as a shared library of functions 
and resources. Dynamic linking enables an executable to call functions or use resources stored in 
a separate file. These functions and resources can be compiled and deployed separately from the 
executables that use them. The operating system can load the DLL into the executable's memory 
space when the executable is loaded, or on demand at runtime. DLLs also make it easy to share 
functions and resources across executables. Multiple applications can access the contents of a 
single copy of a DLL in memory at the same time. 

 

Static linking copies all the object code in a .lib file into an executable. Dynamic linking 
includes only the information needed at run time to locate and load the DLL that contains a data 
item or function. When you create a DLL, you also create a .lib file that contains this information. 
When you build an executable that calls the DLL, the linker uses the exported symbols in the .lib 
file to store this information for the loader. When the loader loads a DLL, the DLL is mapped into 
the memory space of your executable. A special function in the DLL, DllMain, is called to perform 
any initialization the DLL requires. 

 

Using dynamic linking instead of static linking offers several advantages. When you use 
DLLs, you can save memory space and reduce swapping. When multiple applications can use a 
single copy of a DLL, you can save disk space and download bandwidth. DLLs can be deployed and 
updated separately, which lets you provide after-market support and software updates without 
having to rebuild and ship all your code. DLLs are a convenient way to supply locale-specific 
resources, which can support multi-language programs, and ease creating international versions 
of your applications. 

 

Procedure 

 

1. Start a New Windows Desktop Project -> Dynamic Link Library -> Empty Project. 

2. Add a New item -> C++ File(.cpp) and Add New Item -> Header File(.h) 

3. Write out the respective codes for the files. 

4. Open Properties -> Linker -> General -> Enable Incremental Linking =No 

5. Build the project and observe the dll file generated in the Debug Folder. 

6. Start a New Windows Desktop Project -> Console Application -> Empty Project 

7. Add a New item -> C++ File(.cpp)  

8. Write out the respective codes for the file. 



 

9. Open the Properties -> Configuration Properties -> VC++ Directories -> Include 

Directories  

10. Include the path to the debug folder where your (.dll) file is saved. 

 

11. Go to Properties -> Configuration Properties -> VC++ Directories -> Library Directories 

12. Include the path to the debug folder where your (.lib) file is saved. 

13. Go to Properties -> Linker -> Input -> Additional Dependencies 

14. Browse to the (.lib) file and include it 

 

15. You may go to your Windows DLL Application -> Properties -> Build Events -> Post – Build 

Event -> Command Line 

 

16. copy /Y "$(SolutionDir)$(Configuration)\$(ProjectName).dll" "C:\Users\Robert 

Karamagi\Documents\Visual Studio 2017\Experiments\Visual C++\11. 

DLLs\DLLApp\Debug" 

 

17. Or you may copy the files manually into the Debug folder. 

 

Program 

 

Dynamic Link Library 

MyDLL.h 

 
#ifndef MYDLL_H_ 

#define MYDLL_H_ 

 

class  _declspec(dllexport) MyDLL 

{ 

 public: 

  int CalculateFactorial(const int iNum); 

 

}; 

 

#endif  

 

MyDLL.cpp 
#include "MyDLL.h" 

 

int MyDLL::CalculateFactorial(const int iNum) 

{ 

 int iFact = 1; 

 for (int i = 1; i <= iNum; i++) 

 { 



  iFact *= i; 

 } 

 return iFact; 

} 

 

Application 

main.cpp 

 
#include "C:\Users\Robert Karamagi\Documents\Visual Studio 2017\Experiments\Visual 
C++\11. DLLs\DLL\DLL\MyDLL.h" 

#include <iostream> 

 

using namespace std; 

int main() 

{ 

 int iNum = 0; 

 MyDLL* pObj = new MyDLL(); 

 cout<< "\nEnter the number: "; 

 cin >> iNum; 

 cout << "\nThe Factorial is: " << pObj->CalculateFactorial(iNum); 

 cin.ignore(); 

 cin.get(); 

 return 0; 

} 

 

Output 

 
 

 

 

 

 

 

 



 

 

 

 

 
 

 

 

 

 

 

 

 



 

Simple Programs with Control Structures 
 

 

Select Standard EXE and press the Open button 

 

 



 

 

Save your project in a destination of your choice by selecting “File” from the menu and then 

“Save Project As” 

 



Browse for the destination folder of your choice, give a File Name for your Form and then select 

the Save button. 

 

 

 

 

Next give a File Name for your Project and select the Save button. 

 

 

 

Notice the Names for your Project and Form in the Project panel to the right. 



 

 

 

Resize the Form to your design specifications using the size markers at the side of the Form. 

 

 

On the Toolbox to the left, select the “Label” shown with a letter “A”. Once selected hover the 

mouse pointer on your Form and draw a Label Box on your Form of your specified size. 



 

 

 

 

Right click on the Label and select the Properties button. 



 

 

Under the Caption Property, type the name you want to appear on your Label. 

 

 



 

 

Change the Font Style by selecting the Font Option. 

 

 

 

 



Change the Font Color by selecting the Fore Color option in the Properties and under the Palette 

Tab, select a suitable color of your choice. 

 

 

 

 

Change the “BackStyle” in the Properties to 0-Transparent to give a Blending look. 

 

 

 

 

 

Give a suitable alignment to your Label e.g. 2- Center 



 

 

Change the Reference name of your Label which you shall use in your coding. 

 

 

 

Set the “AutoSize” Property to “True” to narrow the dimensions of the Label to the size of the 

contents inside it. 

 

 

 

Select the Pointer in the Tool Box shown by a Mouse Pointer. Once selected click on the Label 

on the Form and move it around to a suitable position. 



 

 

Click on the “PictureBox” in the Tool Box then hover the mouse pointer onto the Form and draw 

it on the Form. 

 

 

Right click on the PictureBox and select Properties. 



 

 

Change the Reference name of the PictureBox to a name that you may easily remember to help 

you recognize it in your coding. 

 

 

 

 

 

  

 

 

Scroll down to the option called “Picture” to select the Picture to go into your PictureBox. 



 

 

Browse for the File Name of your Picture to go onto your PictureBox and selectOpen. 

 

 

 

 

 

Set the “AutoSize” option to ”True” to adjust the dimensions of the PictureBox to be the size of 

the Image inside it. 



 

 

 

 

 

To easily adjust your image to stretch and fit onto your PictureBox you may use any type of 

Pixel Resizer Software to change the dimensions of your image to match that of the PictureBox 

on your Form. Below is an example of resizing your Image using a freeware called PIXresizer.   

 

You start by Loading the Picture, then you select the new size. (It is best to maintain the aspect 

ratio for a decent look.) For the PictureBox in the Visual Basic 6.0 Form an acceptable file 

format is the Joint Photographic Experts Group (JPEG).  Finally save the picture to a folder of 

your choice. 



 

 

Right click on your Form and select Properties. Under the Caption option write the Title to be 

displayed on your Form. 

 



 

 

 

Set the “BorderStyle” to 1-Fixed Single if you would not like the dimensions of your Form to 

change during Run time. 

 

You may change the size of the Form from the Properties: 

The Width Property returns the Form Width 

 

The Height Property returns the Form Height 

 

 

To create an Icon File type “.ico” you may use a freeware such as FormatFactory. 



 

 

Click on the Picture menu and select the ICO button. 



 

 

Start by adding the File to the Window then set the proper output settings. Change the output 

folder of the icon file to that of your choice. Finally click OK. 

Under the “Output Setting” option you may change various settings such as the dimensions of 

your icon file. 



 

 

 

Start the conversion process by selecting the Start button. 

 

 



In your Form Properties click on the Icon option and select the Icon for your Form. 

 

 

 

 

 

To remove the Icon highlight the “(Icon)” text displayed and press the Delete button on your 

keyboard. 

 

 



Set the generalized font style for your entire Form by setting the Font option in your Form 

Properties. 

 

Click the Label icon in the Tool Box and Place Labels for “Result Calculator”, “Physics Mark”, 

Chemistry Mark”, “Mathematics Mark” and “Result” as shown. Set the “AutoSize” to True, 

“BackStyle” to 0 -Transparent and Font and ForeColor to any of your choice. 

 

 



 

 

Place the Text Boxes for Physics Mark, Chemistry Mark, Mathematics Mark and the Result. 

Click on the TextBox Item in the Tool Box. Move to the Form and draw the Text Box with the 

‘+’ sign pointer that will appear. 



 

In the Labels’ Properties give the same Left Property so all Labels may start at the same 

horizontal position. 

 

 

 

 

Right Click on the TextBox and Select the Properties. 



Give the Left Property so all TextBoxes may start at the same horizontal position. 

 

 

Set the Text property to blank. 

 

 

Give a name to define the TextBox e.g. TextPhysicsMark to easily remember it when coding. 

 

 

Set the dimensions of the TextBox. 

 

  

 

Set the Alignment Property to 1 – Right Justify 

 

 

Repeat the following steps for the remaining Text Boxes. 

 

 

 

 

You may finely adjust the height from the Top of the Form of the Labels and Text Boxes using 

the Top Property as shown below. 

 

 

In the Tool Box select the CommandButton and draw it on the Form as shown 



 

 

 

 

Right Click on the button and select Properties. 

Give a name for the Button e.g. CommandShowResults 

 

 

Give the Dimensions of the Button. 



 

 

 

Set the text that the button should display on itself by changing the Caption Property.  

 

 

 

The design phase of the Form is complete therefore we may proceed to the Coding phase.  

N.B. “Design is not Coding and Coding is not Design.” 

 

To start the coding Right click on the Form and select “View Code”. The Form for Coding shall 

appear with the name Form 1 (Code). The Design Form is named as Form 1 (Form). 



 

 

 

 

Go back to the Design Form and Double Click on the “Show Results” button or in the Objects’ 

Drop-down list Select CommandShowResults. 



 

 

The different Procedures associated with the Form Objects are listed in the Drop-down list on the 

right of the window. Select the Click Procedure for the CommandButton. 

 

 

 

 

Enter the code shown in the Sub procedure for the Button Click Event. 

 



 

 

Double-Click on the Form Design Area or in the Objects’ Drop-down list Select Form and, in the 

Procedures’ Drop-down list select Load. 

 



 

 

The Sub Procedure for the Form Loading Event shall appear in the code section. 

 

Place the code TextResult.Enabled = False 

 

 

 

 

 

 

The complete code for the Form is given as: 

 

Private Sub CommandShowResults_Click() 



m1 = Val(TextPhysicsMark.Text) 

m2 = Val(TextPhysicsMark.Text) 

m3 = Val(TextPhysicsMark.Text) 

total = m1 + m2 + m3 

average = total / 3 

If m1 < 40 Or m2 < 40 Or m3 < 40 Then 

TextResult = "Supplementary" 

ElseIf average >= 70 Then 

TextResult = "First Class" 

ElseIf average >= 60 Then 

TextResult = "Upper Second Class" 

ElseIf average >= 50 Then 

TextResult = "Second Class" 

End If 

End Sub 

 

Private Sub Form_Load() 

TextResult.Enabled = False 

End Sub 

 

The Run the Application press F5 or click on the Start icon in the Standard Tools Menu.   

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Adding Menus to Forms 
 

Start a New Visual Basic Project and Select the Standard EXE. 

 

 

Right-Click the Form Window and select the Menu Editor.  

 

Make sure that the Blue Marker Area is set to the first line as shown below to place the first Menu 

Item.  



 

For the First Menu Item: 

Set the Caption = File, the Name = file and give it the Index=0. 

 



To give a sub-menu item for the menu item first click on the Next button so that the Blue Marker 

Area shifts one level down and then click on the right directed arrow to display the four dots 

symbolizing it is a sub-menu. 

 

For the File sub-menu item 1, Set the Caption = New, the Name = new and give it the Index=0. 



 

To place the second sub-menu item for the File menu list first click on the Next button so that the 

Blue Marker Area shifts one level down. The four dots shall appear showing you are still in the 

sub-menu level for the File Menu. 

 



 

For the File sub-menu item 2, Set the Caption = Open, the Name = open and give it the Index=0. 

 

Repeat the step above for the remaining File sub-menu items. Click Next then Set the Caption = 

Save, the Name = save and give it the Index=0. 



 

Click Next and set the Caption = Save As, the Name = saveAs and give it the Index=0. 

 

 

 



 

 

Click Next and set the Caption = Exit, the Name = exit and give it the Index=0. 

 

If you would like to Insert a menu item somewhere, set the Blue Area Marker to a reference point 

and click Insert. The inserted Menu space shall appear above the point where you placed the 

Marker before clicking the Insert button.  



 

 

To Delete a menu item, move the marker to the item by clicking on it once then press the Delete 

button. 

 



Click OK and observe the created File Menu list. 

 

 

 

 

Give a Title to your Form. Right-click on the Form Window and Select Properties. Set the Caption 

= Adding menus to forms. 



 
 

 

 

To add a second Menu List. Open the Menu Editor again by Right-clicking the Form Window and 

selecting the Menu Editor. Click on the Area below the Exit Sub-Menu item so that the marker is 

at the point as shown below. 



 

Set the Caption = Edit, the Name = edit and give it the Index=0. 

 

Click the Next button then press the right arrow once for placing the Edit Sub Menu Items. 



 

Repeat the steps as in the File Menu List for the Edit Menu List. 

 



 

 



 

 



 

 

Add the third Menu list item with a sub-menu and a sub-sub-menu. 

 



 

Click Next and press the right arrow button for the sub-sub-menu item shown with eight dots to 

the side of it. 

 



 

 

 

To move a menu item up or down the hierarchy click on it once so that it is highlighted with the 

blue area marker and press the up or down arrow. 



 

 

 

To make the Menu item checked, click on it once so that it is highlighted with the blue area marker 

and make sure the “Checked” check box is ticked.  



 

 

Add a Text Box to the Form to display the Results of Clicking the Menu Items during Runtime. 



 

You may add shortcuts to the Form Menu items but make sure that it is the lowest sub menu level 

in the hierarchy otherwise you will get an error. 

 

 

Because the lowest level in the File Menu List is the sub-menu with New, Open etc. only they can 

be placed with shortcuts. Likewise, for the Help menu, only the sub-sub menu with the Robert 

Innocent Karamagi menu item can have a shortcut. 



 

You may add new Menu items with the Insert function. 

 



 

 

 



 

 

 

Place the code in the window 

Private Sub about_Click(Index As Integer) 

    Text1.Text = "You Clicked About" 

End Sub 

 

Private Sub copy_Click(Index As Integer) 

    Text1.Text = "You Clicked Copy" 

End Sub 

 



Private Sub cut_Click(Index As Integer) 

    Text1.Text = "You Clicked Cut" 

End Sub 

 

Private Sub delete_Click(Index As Integer) 

    Text1.Text = "You Clicked Delete" 

End Sub 

 

Private Sub edit_Click(Index As Integer) 

    Text1.Text = "You Clicked Edit" 

End Sub 

 

Private Sub exit_Click(Index As Integer) 

    End 

End Sub 

 

Private Sub file_Click(Index As Integer) 

    Text1.Text = "You Clicked File" 

End Sub 

 

Private Sub help_Click(Index As Integer) 

    Text1.Text = "You Clicked Help" 

End Sub 

 

Private Sub new_Click(Index As Integer) 

    Text1.Text = "You Clicked New" 

End Sub 

 



Private Sub open_Click(Index As Integer) 

    Text1.Text = "You Clicked Open" 

End Sub 

 

Private Sub paste_Click(Index As Integer) 

    Text1.Text = "You Clicked Paste" 

End Sub 

 

Private Sub print_Click(Index As Integer) 

    Text1.Text = "You Clicked Print" 

End Sub 

 

Private Sub redo_Click(Index As Integer) 

    Text1.Text = "You Clicked Redo" 

End Sub 

 

Private Sub robert_Click(Index As Integer) 

    Text1.Text = "Robert Innocent Karamagi" 

End Sub 

 

Private Sub save_Click(Index As Integer) 

    Text1.Text = "You Clicked Save" 

End Sub 

 

Private Sub saveAs_Click(Index As Integer) 

    Text1.Text = "You Clicked Save As" 

End Sub 

 



Private Sub undo_Click(Index As Integer) 

    Text1.Text = "You Clicked Undo" 

End Sub 

 

Press F5 to run the Application 

 

 



 

 

If you press the shortcut buttons Ctrl+Z the Form the output will be as shown below. 

 

 

You may add an icon to the Form by opening the Form Properties Window and selecting an icon 

of your choice. 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 



Creating dialog boxes with various options 
 

Start a New Project that is a Standard EXE, 

Right-click on the Form and Select Properties. 

 

 

Give the Title of the Form by setting the Caption Property. 

 



 

 

Right-Click on the Form and select the Menu Editor. 

 

Set up the Menu for the Form 



 

 

 



 

 



 

 

 

 



 

 



 

 

 

Right-Click on the Tool Box and select the Components. 



 

 

In the Controls Tab of the Component Window, Tick the Check Box for the Microsoft Common 

Dialog Control 6.0 and select Apply then close the Window. 

 



Notice the Common Dialog tool that shall appear on the Tool Box. 

 

Click once on the CommonDialog icon in the ToolBox and draw it onto the Form. 

 

 

Notice the Name given to your CommonDialog Control in the Properties Window. 



 

 

Click once on the TextBox tool in the ToolBox and add it onto the Form 

 

 



 

 

Right-Click on the Form and select the View Code option. 

 

 

Paste the following code in the Coding Editor 

Program 

'When the user clicks Open 

Private Sub openMenu_Click(Index As Integer) 

With CommonDialog1 

.DialogTitle = "Open File" 

.InitDir = App.Path 



.Filter = "Text Files (.txt)|*.txt" 

.FilterIndex = 1 

.CancelError = True 

 

Dim fnum As Integer 

 

    On Error Resume Next 

.ShowOpen 

    If Err.Number = cdlCancel Then 

        ' The user canceled. 

        Exit Sub 

    ElseIf Err.Number <> 0 Then 

        ' Unknown error. 

        MsgBox "Error " & Format$(Err.Number) & _ 

            " selecting file." & vbCrLf & _ 

            Err.Description 

        Exit Sub 

    End If 

    On Error GoTo 0 

 

    ' Read the file. 

    fnum = FreeFile 

    Open CommonDialog1.filename For Input As #fnum 

    Text1.Text = Input$(LOF(fnum), fnum) 

    Close #fnum 

End With 

End Sub 

 



 

'When the user clicks Save 

Private Sub saveMenu_Click(Index As Integer) 

    On Error Resume Next 

    CommonDialog1.Filter = "Text Files (.txt)|*.txt" 

    CommonDialog1.filename = "" 

    CommonDialog1.ShowSave 

    CommonDialog1.DialogTitle = "Save As" 

    If LenB(CommonDialog1.filename) = 0 Then 

    Exit Sub 

    End If 

    Dim filename As String 

    filename = CommonDialog1.filename 

    Open filename$ For Output As #1 

    Print #1, Text1.Text 

    Close #1 

End Sub 

 

'When the user clicks Print 

Private Sub printMenu_Click(Index As Integer) 

    CommonDialog1.CancelError = True 

    On Error GoTo PrintErrHandler 

    CommonDialog1.ShowPrinter 

    Printer.Print Text1.Text 

    Printer.EndDoc 

    Exit Sub 

PrintErrHandler: 

    Exit Sub 



End Sub 

 

'When the user clicks Exit 

Private Sub exitMenu_Click(Index As Integer) 

    Dim Result As String 

    Result = MsgBox("Are you sure you want to Exit?", vbCritical + vbYesNo, "Exit") 

    If Result = vbYes Then 

        End 

    End If 

End Sub 

 

'When the user clicks Font 

Private Sub fontMenu_Click(Index As Integer) 

    CommonDialog1.ShowFont 

    Text1.FontName = CommonDialog1.FontName 

    Text1.FontBold = CommonDialog1.FontBold 

    Text1.FontItalic = CommonDialog1.FontItalic 

    Text1.FontUnderline = CommonDialog1.FontUnderline 

    Text1.FontSize = CommonDialog1.FontSize 

    Text1.FontStrikethru = CommonDialog1.FontStrikethru 

End Sub 

 

'When the user clicks Color 

Private Sub colorMenu_Click(Index As Integer) 

    CommonDialog1.ShowColor 

    Text1.ForeColor = CommonDialog1.Color 

End Sub 

 



Output 

Create a text file in the Notepad and Save it with the .txt extension. 

 

 

Open the Text File you created with the running Software. Press F5 to start the application. 

 

 



 

 

 

You may Edit the Contents of the Text Box. 



 

 

 

Save the contents of the Text Box to a File. 

 

 



 

View the previously saved file to verify its genuineness. 

 

 

Change the Font Style. 



 

 

 



 

 

Change the Text Color. 

 



 

 

 

 

 

Print the Contents of the Text Box to a File. 



 

 

 



 

 

Open the Printed Document. 

 

 

You may Exit from the Menu after Confirmation. 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 



MDI Applications 

 

 
Start a New Project that is a Standard EXE. 

Add a Title and Icon to the Form from the Properties. Add a Text Box to the Form as shown.  

 

Change the Alignment Property of the Text Box to “1 – Right Alignment” 

 

 

 

 

 

 



 

 

 

 

Add a Command Button to the Form. 

 

Add the Buttons to the Form to match the layout of a Calculator and clear the Text Property of 

the Text Box. 



 

 

 

Give the respective numbers and symbols on the buttons of the Form. 

 



 

Add a Font Style of your liking. 

 

 

The CommandButton Names are as follows: 

0 : Command0 

1 : Command1 

2 : Command2 

3 : Command3 

4 : Command4 

5 : Command5 

6 : Command6 

7 : Command7 

8 : Command8 

9 : Command9 

+ : CommandPlus 

- : CommandMinus 



× : CommandMultiply 

÷ : CommandDivide 

.  : CommandDecimal 

= : CommandEquals 

C : CommandC 

E : CommandE 

 

Right-click on the Form and select “View Code”. 

Add the following code to your Form’s coding section. 

 

Program 

Dim op, fn As Double 

 

Private Sub Command0_Click(Index As Integer) 

Text1.Text = Text1.Text & 0 

End Sub 

 

Private Sub Command1_Click(Index As Integer) 

Text1.Text = Text1.Text & 1 

End Sub 

 

Private Sub Command2_Click(Index As Integer) 

Text1.Text = Text1.Text & 2 

End Sub 

 

Private Sub Command3_Click(Index As Integer) 

Text1.Text = Text1.Text & 3 

End Sub 



 

Private Sub Command4_Click(Index As Integer) 

Text1.Text = Text1.Text & 4 

End Sub 

 

Private Sub Command5_Click(Index As Integer) 

Text1.Text = Text1.Text & 5 

End Sub 

 

Private Sub Command6_Click(Index As Integer) 

Text1.Text = Text1.Text & 6 

End Sub 

 

Private Sub Command7_Click(Index As Integer) 

Text1.Text = Text1.Text & 7 

End Sub 

 

Private Sub Command8_Click(Index As Integer) 

Text1.Text = Text1.Text & 8 

End Sub 

 

Private Sub Command9_Click(Index As Integer) 

Text1.Text = Text1.Text & 9 

End Sub 

 

Private Sub CommandDecimal_Click(Index As Integer) 

Text1.Text = Text1.Text & (".") 

End Sub 



 

Private Sub CommandC_Click(Index As Integer) 

Text1.Text = "" 

End Sub 

 

Private Sub CommandE_Click(Index As Integer) 

Unload Me 

End Sub 

 

Private Sub CommandPlus_Click(Index As Integer) 

op = 1 

fn = Text1.Text 

Text1.Text = "" 

End Sub 

Private Sub CommandMinus_Click(Index As Integer) 

op = 2 

fn = Text1.Text 

Text1.Text = "" 

End Sub 

 

Private Sub CommandMultiply_Click(Index As Integer) 

op = 3 

fn = Text1.Text 

Text1.Text = "" 

End Sub 

 

Private Sub CommandDivide_Click(Index As Integer) 

op = 4 



fn = Text1.Text 

Text1.Text = "" 

End Sub 

 

Private Sub CommandEquals_Click(Index As Integer) 

If op = 1 Then 

Text1.Text = Val(fn) + Val(Text1.Text) 

ElseIf op = 2 Then 

Text1.Text = Val(fn) - Val(Text1.Text) 

ElseIf op = 3 Then 

Text1.Text = Val(fn) * Val(Text1.Text) 

ElseIf op = 4 Then 

Text1.Text = Val(fn) / Val(Text1.Text) 

End If 

End Sub 

 

Set the From Border style Property to option 1 – Fixed Single. 

 

Browse to the Project Menu and select “Add MDI Form”. 

 



 

Under the “New” Tab in the window that appears, select “MDI Form” and click on the “Open” 

button. 

 

 



 

Notice the Project Window showing the Form1 and the MDIForm1. 

 

Add the Menu Bar to the MDIForm. Right-click on the Form and select the Menu Editor option. 



 

 



 

 

 

 

In the Form1 Properties set the MDIChild Property to True. 



 

 

Right-click on the MDIForm1 window and select “View Code”. 

 

Place the code in the window. 

 

Program 

Private Sub MDIForm_Load() 

Me.Height = 7000 

Me.Width = 7000 

Form1.Show 

Form1.Height = 5475 

Form1.Width = 5055 

Form1.Left = 0 

Form1.Top = 0 

End Sub 

 

Private Sub calculator_Click(Index As Integer) 

Form1.Show 

Form1.Height = 5475 

Form1.Width = 5055 

Form1.Left = 0 

Form1.Top = 0 

End Sub 

 



Private Sub exit_Click(Index As Integer) 

    Dim Result As String 

    Result = MsgBox("Are you sure you want to Exit?", vbCritical + vbYesNo, "Exit") 

    If Result = vbYes Then 

        End 

    End If 

End Sub 

 

Press F5 to run the Application. 

Select the New Menu item and click on the Calculator option or Press Ctrl + N.  

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Writing code for various keyboard and mouse events 

 

 
Start a New Standard EXE Project. 

 

In the Tool Box, select the Shape Tool and draw a Shape on the Form as shown below. 

 

 

 

Set the Shape Properties. 



BackColor : Any color 

BackStyle : 1 - Opaque 

Shape : 3 – Circle 

  

Set the Form1 Properties 

Caption : Keyboard Events 

Icon : Any keyboard icon 

 



 

 

Add a Text Box to the Form to give details of the Keyboard Event. The name is referred to as 

Text1 



 

 

Add the Code to the Form1 for the Keyboard Events. 

Program 

Private Sub Form_Load() 

Text1.Enabled = False 

End Sub 

 

 

Private Sub Form_KeyDown(KeyCode As Integer, Shift As Integer) 

Select Case KeyCode 



 

Case vbKeyUp 

Shape1.Top = Shape1.Top - 50 

 

Case vbKeyDown 

Shape1.Top = Shape1.Top + 50 

 

Case vbKeyLeft 

Shape1.Left = Shape1.Left - 50 

 

Case vbKeyRight 

Shape1.Left = Shape1.Left + 50 

 

End Select 

End Sub 

 

 

Private Sub Form_KeyUp(KeyCode As Integer, Shift As Integer) 

Select Case KeyCode 

Case vbKeyUp 

Text1.Text = "You moved Up" 

 

Case vbKeyDown 

Text1.Text = "You moved Down" 

 

Case vbKeyLeft 

Text1.Text = "You moved Left" 

 



Case vbKeyRight 

Text1.Text = "You moved Right" 

End Select 

End Sub 

 

In the Visual Basic Menu Bar select the Project Menu and click on the Add Form option. In the 

New tab, select Open. 

 

A new Form shall appear in the Project Window. 

 

 

Add the Labels, Text Boxes and a Command Button as shown. 

In the Form Properties add a title and Icon. 



Caption : Mouse Events 

Icon : Any Icon 

 

The Text Boxes are named TextXPosition, TextYPositon and TextStatus. 

The button is named CommandButton1. Set the Caption to nothing. 

 

 

Add the code to the Form2 for the Mouse Events. 

Program 

Private Sub Form_Load() 

TextXPosition.Enabled = False 



TextYPosition.Enabled = False 

TextStatus.Enabled = False 

End Sub 

 

Private Sub Form_MouseMove(Button As Integer, Shift As Integer, X As Single, Y As Single) 

TextXPosition.Text = X 

TextYPosition.Text = Y 

If Button = 1 Then 

Form2.FillStyle = vbSolid 

Form2.FillColor = vbBlue 

Form2.Circle (X, Y), 50 

End If 

End Sub 

 

Private Sub Command1_MouseDown(Button As Integer, Shift As Integer, X As Single, Y As 

Single) 

Command1.Caption = "Down" 

TextStatus.BackColor = vbGreen 

TextStatus.Text = "The Mouse is Down" 

End Sub 

 

Private Sub Command1_MouseUp(Button As Integer, Shift As Integer, X As Single, Y As 

Single) 

Command1.Caption = "Up" 

TextStatus.BackColor = vbRed 

TextStatus.Text = "The Mouse is Up" 

End Sub 

 

 



Add an MDIForm to the Project. 

 

 

Set the Properties of Form1 and Form2: 

MDIChild : True 

BorderStyle : 1 - Fixed  

 

 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Create a Menu for the MDIForm using the Menu Editor. 



 

 

 

 

 



 

 

 



 

 

Add the MDIForm title from the Caption Property. 

 

 

Add the Code for the MDIForm. 



Program 

Private Sub MDIForm_Load() 

Me.Height = 10000 

Me.Width = 10000 

Form1.Height = 8000 

Form1.Width = 8000 

Form2.Height = 8000 

Form2.Width = 8000 

End Sub 

 

Private Sub keyboard_Click(Index As Integer) 

Form1.Show 

Form1.Top = 0 

Form1.Left = 0 

End Sub 

 

Private Sub mouse_Click(Index As Integer) 

Form2.Show 

Form2.Top = 0 

Form2.Left = 0 

End Sub 

 

Private Sub exit_Click(Index As Integer) 

    Dim Result As String 

    Result = MsgBox("Are you sure you want to Exit?", vbCritical + vbYesNo, "Exit") 

    If Result = vbYes Then 

        End 

    End If 



End Sub 

 

Press F5 to run the application. 

 

 



 

 



 



 

 



 

 

 

 

 

 

 

 

 

 



 

OLE Container Control 

 
Start a New Standard EXE Project. 

 

In the Tool Box, select the OLE Tool and Draw the control on the Form as shown below. 

 

 

 

 



Add the Command Buttons to the Form. 

Insert Object : CommandInsert 

Run Object : CommandRun 

Delete Object : CommandDelete 

 

Edit the Form1 Properties. 

BackColor : Any Color 

BorderStyle : 1 - Fixed Single 

Caption : OLE Container Control 

Font : Any Font 

Icon : Any Icon 

 

 

 

Open the coding section of the Form and paste the following code. 

 

Program 

Private Sub CommandInsert_Click() 

On Error Resume Next 

OLE1.Action = 14 



End Sub 

 

Private Sub CommandRun_Click() 

On Error Resume Next 

OLE1.Action = 7 

End Sub 

 

Private Sub CommandDelete_Click() 

On Error Resume Next 

OLE1.Delete 

End Sub 

 

Press F5 to run the application. 

 

 

Click on the Insert Object button. 



 

 

Select the Create from File Radio Button and click on the Browse button to search for an Object 

to Insert into your Form. 

 

 

Click the OK button to Insert the Object. 



 

 

 

 

 

 

Notice that your Form is now Embedded with the Object and is linked to the application 

responsible for running it. 

 

 

Click on the Run Object button to invoke the methods concerned with the object. 



 

 

 



 

 

As the Application is running the OLE Window of your Form shall be shaded with diagonal 

lines. 

 



You may Delete the Object with the Delete Object button and run another Object. 

 
 

 
 


